• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Permission Issue!

Gabby

Well-known member
#1
Ho hum....

I have permission issues.

All of my admin permissions are set ok, all forum permission are set ok yet I'm missing most ability to moderate threads or posts. There is no drop down list to moderate threads except on admin threads and then there is just the ability to delete, nothing else. All I have is a "watch thread" link above forums right hand side with member generated threads.

So WTH is going on? :( SOOOOOOOOOO frustrated with XF and myself.

Thanks

Gabby
 

Will

Active member
#2
Double check that you don't have the never option set any areas.

I can take a look at it for you if you would like. Just shoot me a pm. :)
 

Arty

Well-known member
#3
In user group permissions (click "users" tab, select "user group permissions" on bottom left) select your group, in "Forum Moderator Permissions" section set "yes" to all options.
 

MagnusB

Well-known member
#4
Add your self as a moderator, some permissions are locked to moderators and not user group permissions. Users - Moderators - Add new Moderator. It isn't enough to just add your self in the moderator user group.
 

Gabby

Well-known member
#5
Hello Everyone,
Thank you for all your suggestions. I've done all of the above over and over again. I just tested a demo community and it appears am indeed missing some things.

I'll check yet another time and see.

THANK YOU! :)
 

MagnusB

Well-known member
#6
Try to switch to the default style (even if it is disabled, admins can select it) and see if they are present there. Then there is probably a template issue.
 

Gabby

Well-known member
#7
Ok I have checked everything again. I'm mod and admin and still have to mod abilities other than stated above. I don't even have the check box next to each post to select. Somethings is haywire and this time I don't think it's my brain. LOL But hell, I've been wrong before.
 

Gabby

Well-known member
#8
Try to switch to the default style (even if it is disabled, admins can select it) and see if they are present there. Then there is probably a template issue.
Tried this as well. I don't have any mods that would cause template issue as they are standard and I haven't seen any issue posted here regarding a mod that I have and permission issues.

I dunno.
 

Will

Active member
#9
Is this a fresh install?

It's kind of hard to tell what is going on. If you could maybe post some screenshots of your permissions maybe someone can see what you got going on.
 

MagnusB

Well-known member
#10
I am not sure then. Have you tried running a file health check?

Also, have you checked the source of the page to see if the html is present? Check a thread for moderation, then select view source and then search for <optgroup label="Moderation Actions"

Below that you should see all the options.
 

Gabby

Well-known member
#11
Thank you Magnus, I just ran a file health check as you were posting this and all is well. I cannot check the thread for moderation as there is no check box present.
 

Gabby

Well-known member
#12
Is this a fresh install?

It's kind of hard to tell what is going on. If you could maybe post some screenshots of your permissions maybe someone can see what you got going on.
Thank you Will. No this isn't a free install. And I'll post some screen shots in a few.
 

MagnusB

Well-known member
#13
Thank you Magnus, I just ran a file health check as you were posting this and all is well. I cannot check the thread for moderation as there is no check box present.
Well, that is a problem. Check the template thread_view and see if this is present:
Code:
<xen:if is="{$thread.canInlineMod}">
<form action="{xen:link inline-mod/thread/switch}" method="post" class="InlineModForm sectionFooter" id="threadViewThreadCheck" data-cookieName="threads">
<label><input type="checkbox" name="threads[]" value="{$thread.thread_id}" class="InlineModCheck" /> {xen:phrase select_for_thread_moderation}</label>
<input type="hidden" name="_xfToken" value="{$visitor.csrf_token_page}" />
</form>
</xen:if>
If not, add it after this bulk of code:
Code:
<xen:if hascontent="true">
<form action="{xen:link threads/quick-update, $thread}" method="post" class="AutoValidator">
<ul class="secondaryContent blockLinksList checkboxColumns">
<xen:contentcheck>
<xen:if is="{$canLockUnlockThread}">
<li><label><input type="checkbox" name="discussion_open" value="1" class="SubmitOnChange" {xen:checked $thread.discussion_open} />
{xen:phrase open_thread}</label>
<input type="hidden" name="set[discussion_open]" value="1" /></li></xen:if>
<xen:if is="{$canStickUnstickThread}">
<li><label><input type="checkbox" name="sticky" value="1" class="SubmitOnChange" {xen:checked $thread.sticky} />
{xen:phrase sticky}</label>
<input type="hidden" name="set[sticky]" value="1" /></li></xen:if>
</xen:contentcheck>
</ul>
<input type="hidden" name="_xfToken" value="{$visitor.csrf_token_page}" />
</form>
</xen:if>
 

MagnusB

Well-known member
#19
As I said, I can take a look at it for you, but my guess is that you are not a moderator. If you go to the users tab in the admin CP, you will see a menu on the left hand side, click on Moderators there. Are you present there? If not, add your self there, check off everything and try again. This is kinda wonky with xF permissions, they are quite often double placed, though for moderator and admin, many of them are tied to the moderator permissions, not user group permissions.
 

Will

Active member
#20
Actually, you don't need to be added as a moderator to have those abilities. Being an administrator or in any usergroup for that matter with the proper permissions would give you access to that stuff.

With this issue at hand, I have no idea what is going on.