Not a bug Period being added by editor automatically

Affected version
2.2.0 Beta version installed here

Jake B.

Well-known member
For some reason the editor is automatically adding a period after words automatically when pressing space twice. I've confirmed this using both Brave
Version 1.9.80 Chromium: 81.0.4044.138 (Official Build) (64-bit) as well as Chrome Version 84.0.4147.105 (Official Build) (64-bit)

This happens while using the rich text editor, or while using the raw BBCode editor.
 

Mendalla

Well-known member
Replicated using Google Gboard on Android. I think it may be the keyboard, not the editor, that does it because it does not do it when I try in Windows. Both phone and computer use Edge Chromium.
 

Chris D

XenForo developer
Staff member
Yeah main reason I asked about the OS is because a significant bunch of OS' do allow double space to add a period as a shortcut. It's default on iOS, macOS and it seems on Android too, depending on the keyboard, though some keyboards may require you to explicitly enable it in its settings.

I think the same behaviour will not only be replicable on XF 2.1, 2.0 and 1.5 but also on pretty much any text input including native HTML 5 ones on the web.

It's not an XF bug. It's a device/OS feature.
 

Jake B.

Well-known member
Yeah main reason I asked about the OS is because a significant bunch of OS' do allow double space to add a period as a shortcut. It's default on iOS, macOS and it seems on Android too, depending on the keyboard, though some keyboards may require you to explicitly enable it in its settings.

I think the same behaviour will not only be replicable on XF 2.1, 2.0 and 1.5 but also on pretty much any text input including native HTML 5 ones on the web.

It's not an XF bug. It's a device/OS feature.

Yeah, looks to be the case. I had it toggled off for ages, must've gotten reverted somehow
 
Top