Fixed Smilies and images getting removed from editor automatically after inserting

Affected version
2.1.3

Andro

Well-known member
Strange issue after upgrading to 2.1.3

To reproduce:

Enter any/a few emojis and hit enter. Emojis will be deleted. Same happens with images too. They didn't show up and get auto deleted after clicking on insert (note: we are trying with remote images via URLs).

This is causing huge inconvenience as members are unable to upload any media. They can enter emojis from other editors like mobile phone and keyboard, those work as they are utf8 based emojis which converts into image only upon submission.

Everything was fine before the upgrade.
 

Chris D

XenForo developer
Staff member
I think we need more information from you exactly how these smilies and defined. Particularly you mention something about remote images? That might be key to us reproducing the issue.

Clearly the issue isn’t happening here so there must be something specific about the smilies which get deleted. If you can share the details of the smilies such as the image replacement URL etc that will be helpful.
 

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue. It has now been resolved and we are aiming to include it in a future XF release (2.1.4).

Change log:
Fix some slightly over-zealous image removal code in the editor if image uploads are not supported.
Any changes made as a result of this issue being resolved may not be rolled out here until later.
 

Chris D

XenForo developer
Staff member
The issue seems specific to the fact that you have image uploads disabled in the editor.

If you can download this file and upload it to your server and replace the existing js/xf/editor-compiled.js file, that should sort it. You might need to hard refresh in the browser for the new file to be picked up.

If after a hard-refresh the issue does not appear to be fixed, you can go to your install page and "Rebuild master data". This will simply rebuild some caches and change our JavaScript cache buster strings.
 
Last edited:

deslocotoco

Well-known member
The issue seems specific to the fact that you have image uploads disabled in the editor.

If you can download this file and upload it to your server and replace the existing js/xf/editor-compiled.js file, that should sort it. You might need to hard refresh in the browser for the new file to be picked up.

I just tried that but the problem persists. I don't disabled any image uploads.

I did opened the Forum in the Private Navigation to have a clear cache, but I'm still facing the problem.

I reported too this issue, but didn't see this thread before, so, sorry.

Btw, the health check:

1563424778545.png
 

dknife

Well-known member
Confirmed the updated javascript has resolved this issue for me as I do not have attachment upload enabled for regular users.
 

Chris D

XenForo developer
Staff member
The issue seems specific to the fact that you have image uploads disabled in the editor.

If you can download this file and upload it to your server and replace the existing js/xf/editor-compiled.js file, that should sort it. You might need to hard refresh in the browser for the new file to be picked up.

If after a hard-refresh the issue does not appear to be fixed, you can go to your install page and "Rebuild master data". This will simply rebuild some caches and change our JavaScript cache buster strings.
The fix is right here.
 

HappyWorld

Well-known member
you can go to your install page and "Rebuild master data". This will simply rebuild some caches and change our JavaScript cache buster strings.
If i do "rebuild master data", will i lose custom phrase change & template change that i manually did (not from template modification system)?
 

Chris D

XenForo developer
Staff member
In case you missed it, the instructions for the fix are here:
The issue seems specific to the fact that you have image uploads disabled in the editor.

If you can download this file and upload it to your server and replace the existing js/xf/editor-compiled.js file, that should sort it. You might need to hard refresh in the browser for the new file to be picked up.

If after a hard-refresh the issue does not appear to be fixed, you can go to your install page and "Rebuild master data". This will simply rebuild some caches and change our JavaScript cache buster strings.
 
Top