XF 2.2 PDF Files Won't Attach

We have been looking into how to allow PDF uploads (with a maximum size of say 50 MB).

Preferably, we would want to attach the PDFs, rather than, embed them.

Currently, when users of our forum press "attach", and chose a PDF, it looks like it uploads, but, when they post their message, the PDF is nowhere to be found.

We have looked here, here, and here, and haven't been able to figure it out yet.

Is an add-on needed for this?

Or is just a few settings we haven't found yet? If so, could someone kindly point us to which settings these are & what they need to be set to?
 

Brogan

XenForo moderator
Staff member
Do small PDF files upload?

Such as this one.

If not, press F12 and select the Console tab and check for errors.
 

Attachments

  • pdf-test-file.pdf
    13 KB · Views: 4
Do small PDF files upload?

Such as this one.

If not, press F12 and select the Console tab and check for errors.
That small PDF test file didn't work either.

Opening Console (with ctrl + shift + J on Brave browser, Ubuntu) doesn't show much:

Screenshot from 2021-06-25 21-07-23.png

That is also what shows up on other pages on the forum (not just the one where we tried the test PDF). Checked this on Google Chrome as well, same deal.

The PDF file type attachments are turned on here:

Screenshot from 2021-06-25 21-09-45.png
 

jeb35

Well-known member
Most likely this an issue with the server side most likely being mod security. Contact your host to have them find out what rule was triggered and have them whitelist it.
 

Brogan

XenForo moderator
Staff member
The 404 error is unrelated. It's due to a missing bg1.png file.

Most likely it's something server side but I would have expected some sort of error message.
 
Top