1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 ParseError: syntax error, unexpected 'cbuarm' (T_STRING)

Discussion in 'Troubleshooting and Problems' started by click here, Jul 3, 2016.

  1. click here

    click here Active Member

    Anyone have this error or know what it is?

    ParseError: syntax error, unexpected 'cbuarm' (T_STRING) - library/XenForo/Template/Abstract.php(265) : eval()'d code:541
    Generated By: Unknown Account, Yesterday at 5:12 AM

    Stack trace:

    #0 /home/user/mysite/forums/library/XenForo/Template/Abstract.php(191): XenForo_Template_Abstract->_renderInternal('$__output = '';...', Array)
    #1 /home/user/mysite/forums/library/XenForo/Template/Public.php(110): XenForo_Template_Abstract->render()
    #2 /home/user/mysite/forums/library/XenForo/ViewRenderer/HtmlPublic.php(140): XenForo_Template_Public->render()
    #3 /home/user/mysite/forums/library/XenForo/FrontController.php(637): XenForo_ViewRenderer_HtmlPublic->renderContainer('\n\n\n\n\n<div class...', Array)
    #4 /home/user/mysite/forums/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_Error), Object(XenForo_ViewRenderer_HtmlPublic), Array)
    #5 /home/user/mysite/forums/index.php(13): XenForo_FrontController->run()
    #6 {main}
     
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Just taking a guess.. but what version of PHP are you on?
     
  3. click here

    click here Active Member

  4. Tracy Perry

    Tracy Perry Well-Known Member

    OK.. that knocks out an older version.. but the current is 7.0.8, and there are several bug fixes out since 7.
    Check your file health check from the ACP and restart your php processor in case it's related to the opcode cache (and these are just guesses from issues I've seen).
     
  5. click here

    click here Active Member

    Looks like my host is only at 7.0 at the moment, everything looks good as far as file health check.
     
  6. Mike

    Mike XenForo Developer Staff Member

    Can you make a dump of your xf_template_compiled table and send it to me in a conversation?

    Once you do that, go to <url>/install/ and rebuild the master data. That should force a template recompile.
     

Share This Page