Resource icon

Page as portal homepage

Catmes

Member
Glad you got it sorted out. I did experience a long load time with the homepage today, though, as Mr Lucky did yesterday. If you get complaints from others about it, you might want to try deleting that addon. Aside from possible security risks, it probably hasn't been updated in a very long time. There are other statistics addons around if you're ever looking to replace it with something.
For me, accessing my homepage is very fast, less than 2 seconds can be said. My country often has a broken internet cable to international, maybe that's why you load the page for a long time.
Or maybe there's a little glitch every now and then, I don't think it matters much.
I also know that Addon is old. But for the time being, I don't know how to find the latest one to replace it properly.
Thank you very much for your interest in the matter I asked
 

imno007

Well-known member
For me, accessing my homepage is very fast, less than 2 seconds can be said. My country often has a broken internet cable to international, maybe that's why you load the page for a long time.
Or maybe there's a little glitch every now and then, I don't think it matters much.
I also know that Addon is old. But for the time being, I don't know how to find the latest one to replace it properly.
Thank you very much for your interest in the matter I asked
Could be several things, but just saying I would look at it as a likely culprit if you continue to get complaints about slow load times only on the homepage. And there probably is not a newer version of it. I don't believe the company that released it have been updating any of their addons since they were banned from xenforo.com.

You could create an html widget and add various tabbed widgets yourself, but here's a few useful addons for possible future reference, allowing for different approaches:




There's others, of course. You'd just have to look around. Good luck!
 

Catmes

Member
Could be several things, but just saying I would look at it as a likely culprit if you continue to get complaints about slow load times only on the homepage. And there probably is not a newer version of it. I don't believe the company that released it have been updating any of their addons since they were banned from xenforo.com.

You could create an html widget and add various tabbed widgets yourself, but here's a few useful addons for possible future reference, allowing for different approaches:




There's others, of course. You'd just have to look around. Good luck!
Well thank you so much for suggesting me
 

Superswip

New member
Hi,

I have completed all the instructions in the article. I now have a home page, but none of the widgets inserted in the template HTML are appearing. Do you happen to have any ideas why?
 

Wing

Active member
Hi,

I have completed all the instructions in the article. I now have a home page, but none of the widgets inserted in the template HTML are appearing. Do you happen to have any ideas why?
Same issue here... my code looks identical to what directions say. But no widgets are appearing.
 

Wing

Active member
Are you editing the right template? Is your page index set correctly?

I am attempting to inject this code into the "home" node template:

<xf:widget key="mediaslider"/>

<xf:widget key="Poll" position="sidebar"/>

<xf:widget key="forum_overview_new_posts" position="sidebar"/>

<xf:widget key="forum_overview_members_online" position="sidebar"/>

<xf:widget key="forum_overview_forum_statistics"/>

Homepage shown here: https://www.v57thwing.com/index.php?pages/home/
 

RobParker

Well-known member
and the _page_node.24 template hasn't been edited otherwise? Maybe check it has what you expect in it for your style.
 

RobParker

Well-known member
and you're sure you have all those widgets defined correctly?

Maybe edit it to just be one of the standard ones and check if that works.
 

click here

Active member
It's still the correct place to post for support with it.

@Muddy Boots - yes, install XF in the domain root if you want a home page at example.com and the forums at example.com/forums .
Question, wouldn't moving the forum from example.com/forums to example.com mess up all the internal and external links etc.? Would you have to apply redirects for everything?
 

click here

Active member
Yes, rewrites would be required if the URLs change.
Thanks, any other changes, like in config files or with add-ons?
Also, would it be safer to at first "copy" all the XF files to the root directory instead of "move" just in case something goes horribly wrong?
 
Top