1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Outdated template notice after customizing template

Discussion in 'Resolved Bug Reports' started by Arty, Jan 21, 2012.

  1. Arty

    Arty Well-Known Member

    Yesterday I've customized template moderator_bar.css on my forum, today after logging in I noticed a message saying that moderator_bar.css is outdated. Version number is empty:
    I've reverted it and then applied changes again, still getting same notice. Forum version is 1.1.1

    Is it a bug?
  2. Brett Peters

    Brett Peters Well-Known Member

    Watching thread
    I have reverted some templates to find out they just revert to a prior edit instead of original :confused:
  3. Mike

    Mike XenForo Developer Staff Member

    How did you customize it, via the control panel or WebDAV?

    That's really unrelated to this issue - and probably working as expected, either reverting to a parent version of the template or just keeping the style properties intact.
  4. Arty

    Arty Well-Known Member

    Via control panel. Styles tree looks like this:

    Master Style (moderator_bar.css has correct version)
    - Default Style (moderator_bar.css is not customized)
    - - Style #1 (moderator_bar.css is customized and has correct version, installed via xml upload)
    - - - Style #2 (moderator_bar.css is customized via control panel, missing version number)
  5. Brett Peters

    Brett Peters Well-Known Member

    Obviously I am missing something so I will look into it further but No parent styles were present and I was editing a stock standard template with no extra .css or style properties but yet after making a series of edits on a fresh template and then reverting seems to occasionally revert the template to a previous edit and then shows that the template is outdated.

    But because it is unrelated I shall leave this thread alone
  6. Arty

    Arty Well-Known Member

    I've reverted template, checked that it was reverted and edited it again, this time via WebDav. Version number was empty again and template was listed in outdated templates list.

    My guess is it has something to do with customizing template that was already customized in parent style.
  7. Arty

    Arty Well-Known Member

    I've tried to reproduce that bug with anything other than my test style, but can't do it.

    It seems to affect all child styles of Style #1. I've checked xml file that was used to import that style, it is correct and moderator_bar.css does have a version number. Installed it again, created child style, modified moderator_bar.css in child style, it had empty version number.

    Style #1 is in attachment.

    Attached Files:

  8. Arty

    Arty Well-Known Member

    I've done more tests. Even though master style has version 1.0.0 Release Candidate 3, when editing child style and exporting it, version number changes to 1.1.1. Also addon_id was missing.

    So I've changed version numbers and addon_id for all templates in that XML file before importing it again and it fixed this issue.

    I think it is a bug in XenForo: if template in parent style had incorrect version number, why wasn't it listed in outdated templates list, but same template customized in child style was?
  9. Mike

    Mike XenForo Developer Staff Member

    The version number wasn't incorrect - it reflects when the template was last edited. You edited it while running 1.1.1; the master was last edited during the 1.0 RC.

    This issue is ultimately caused by the lack of addon_id in that style XML. That's what I need to figure out how to reproduce. I've tried what I thought would trigger it, but I'm not having any luck. Did you first customize those templates ages ago? As it was likely a bug in the past that has since been fixed, but it's not a retroactive fix (you'd have to revert and re-customize to pick it up).
  10. Arty

    Arty Well-Known Member

    In that case its not a xenforo bug, but a my mistake.

    I've merged templates.xml and style_properties.xml in order to extract templates and properties that have color values (for my colorizeit editor). Templates in default templates.xml don't have addon_id, so when merged xml file was imported to xenforo, addon_id didn't exist. Then when it was exported, xenforo added addon_id with empty value because it was empty when xml was imported.
    Mike likes this.
  11. Michael Banks

    Michael Banks New Member

Share This Page