Option_javaScriptSource Removed from Performance Tab?

Junior

Well-known member
I'm not sure if this is just a bug on my end or this was removed for changes in 1.1 but when I go to the Performance tab in Admin options I can no longer choose the location of javascript files. Did I miss something? :)
 

Brogan

XenForo moderator
Staff member
1.1 hasn't yet been rolled out so your site can only be 1.0.4 at the most.

It's still there under the Performance tab, at the bottom of the page.
 

James

Well-known member
I don't see it under the Performance tab, the last thing on mine is the jQuery source (and I have debug enabled).
 
F

Floris

Guest
Maybe he meant in anticipation for changes to come in 1.1, already done now, in 1.0.4
 

James

Well-known member
There used to be an option that allowed you to specify a URL to move JS to. I think it was replaced with a config variable though.
 

Brogan

XenForo moderator
Staff member
Ah, that was changed a while ago.

http://xenforo.com/community/threads/xenforo-enabling-cdn-for-static-content-and-javascript-done.14902/#post-195151

Note that the JavaScript source option has been removed in 1.0.2, and replaced with a new config variable, together with a new external data URL config variable, allowing us to also serve avatars and attachment thumbnails from a different source.

This is in the config file for xenforo.com:
PHP:
// Requires XenForo 1.0.2
$config['externalDataUrl'] = 'http://xenforo.net/community/data';
$config['javaScriptUrl']  = 'http://xenforo.net/community/js';
 
Top