1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 option.php error on line 1052

Discussion in 'Installation, Upgrade, and Import Support' started by Lone Wolf, Feb 11, 2012.

  1. Lone Wolf

    Lone Wolf Well-Known Member

    I'm trying to install 1.1.1 as a development forum and I keep getting the following error during the installation...

    Code:
    Fatal error: Class 'XenForo_DataWriter_Option' not found in /home/site/test/library/XenForo/Model/Option.php on line 1052
    How do I fix this?
     
  2. Lone Wolf

    Lone Wolf Well-Known Member

    This is line 1052...

    Code:
                $groupDw->setOption(XenForo_DataWriter_Option::OPTION_REBUILD_CACHE, false);
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    Try uploading the files again, it could be due to problems during the FTP process.
     
  4. Lone Wolf

    Lone Wolf Well-Known Member

    i uploaded option.php again a few times, i even used the option.php file from 1.1.2 but that didnt help either
     
  5. Jeremy P

    Jeremy P Well-Known Member

    It's not library/XenForo/Model/Option.php that's missing, it's library/XenForo/DataWriter/Option.php. Might as well do the whole upload again to make sure nothing else is missing.
     
  6. Lone Wolf

    Lone Wolf Well-Known Member

    Im trying that now JP & Brogan
     
  7. Lone Wolf

    Lone Wolf Well-Known Member

    I reinstalled everything and now Im getting these errors...

     
  8. Lone Wolf

    Lone Wolf Well-Known Member

    Im getting different errors now
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    It sounds to me as if you're having FTP issues and/or corruption.
    Which client are you using?

    Try re-downloading the .zip package from your customer area and using a different FTP client.
     
    Lone Wolf likes this.
  10. Lone Wolf

    Lone Wolf Well-Known Member

    Im using file zilla and i've tried redownloading the zip as well
     
  11. Lone Wolf

    Lone Wolf Well-Known Member

    I've downloaded it onto a different computer and will try and upload it from there instead
     
  12. Lone Wolf

    Lone Wolf Well-Known Member

    Thanks Brogan/JP, you were right. Must be something wrong with this laptop/ftp program

    It installed first time from the other laptop
     

Share This Page