1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 openbase_dir issue

Discussion in 'Installation, Upgrade, and Import Support' started by kankan, Feb 13, 2015.

  1. kankan

    kankan Active Member


    I own a live forum at /home/e-smith/files/ibays/forumasus/html/www running 1.1.3

    I am setting up a new forum next in this folder :
    /home/e-smith/files/ibays/forumasus/html/forum running 1.4.3

    I originally set a /tpm dir to work with my live forum and all is working ok :

    When i try to upload a ressource, image, avatar etc with the new forum, i get this error :
    Does 1.4 manage /tmp dir the same way than 1.3 ?

    We set /tmp directory outside /html directory for security reason and avoid that session could be stolen from other /html services.

    Anyway to fix this issue is the most welcomed.

    Kind regards

    Env : PHP Version 5.3.3
    Last edited: Feb 13, 2015
  2. Mike

    Mike XenForo Developer Staff Member

    You generally want to add /tmp to the open_basedir at least to deal with uploaded files for example or other temporary files.

    In this case, it looks like it was a file created by XF which probably means the attempt to create it in the internal_data/temp directory failed for some reason. That would likely be PHP falling back to it.
  3. kankan

    kankan Active Member

    Thank you Mike, il will investigate in this way.
    Last edited: Feb 13, 2015
  4. kankan

    kankan Active Member

    Solved by chmoding /internal_data/ correctly. Thank you.

Share This Page