one of my users never receives confirmation email

jacko

Well-known member
One of my users is trying to change email address but whatever email address he uses - there is no confirmation email... I even signed in using his login credentials, I tried to use several of my email addresses and nothing... I have some other test accounts and everything is fine - confirmation email arrives at every change.
 

jacko

Well-known member
I can send email to this user from admin control panel - it is just confirmation email that never arrives...
 

Dean

Well-known member
I am extremely interested in what is happening. On our (currently still vb3) forum we have had random issues for years.

You have a situation that is not only repeatable, but the member shared the login credentials with you.
 

jacko

Well-known member
the user does not receive notification emails either (eg. new private message notification)
 

Jake Bunce

XenForo moderator
Staff member
It sounds like outgoing emails are working fine. More than likely this is a problem with a spam filter on the receiving end. Unfortunately this is very common. If you want to confirm delivery then you can examine the mail logs on your server. Otherwise you usually just have to tell the user to use a different email address.
 

jacko

Well-known member
It sounds like outgoing emails are working fine. More than likely this is a problem with a spam filter on the receiving end. Unfortunately this is very common. If you want to confirm delivery then you can examine the mail logs on your server. Otherwise you usually just have to tell the user to use a different email address.
You didn't read my posts carefully enough. I eliminated possibility with spam filters.

UPDATE: THE PROBLEM IS SOLVED

From admin control panel I changed the user state to "valid" and from now on the user started receiving confirmation emails when changing addresses. Of course the user state went back to "Awaiting confirmation (from edit)" but now it works as expected.

Users database was imported from vBulletin so now I am going to check if the problem will be the same for other users.
 

jacko

Well-known member
I asked some other users to change their email addresses and everything is working fine. At this point it is impossible for me to repeat this error.
 

Dean

Well-known member
Thank you very much for you articulate input. I will keep an eye on this issue, your input may have helped others.
 

jacko

Well-known member
There was another user with the same problem. I clicked "save" in his profile in Admin CP and the problem was solved.
 

jacko

Well-known member
3rd user had the same problem!

I need a fix. Basically I need a script that will re-save all user profiles. I can't re-save manually almost 3000 profiles.
 

Brogan

XenForo moderator
Staff member
Do you just want to set all users to valid?
You can do that with this query: UPDATE xf_user SET user_state = 'valid';

That will set all users though.
Ensure you take a backup of your database first.
 

jacko

Well-known member
repeatable solution to this problem is this:
There was another user with the same problem. I clicked "save" in his profile in Admin CP and the problem was solved.
I don't need to change anything. Just clicking "save" unlocks activation emails.

Let me remind that it is related only to users imported from VBulletin.
 
Top