1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Old user name shows even after being changed

Discussion in 'Resolved Bug Reports' started by Saeed, Apr 16, 2011.

  1. Saeed

    Saeed Well-Known Member

    Hi guys.

    I've noticed this bug previously as well but couldn't get you a "live" one so you could have a look at it for yourselves.

    Basically, let's assume there is a user by the user name "123" which is changed to "789".

    All posts which 123 had liked still show as "123 liked this post", instead of changing to "789 liked this post". I noticed this once, and since I was about to like the same post as well, after liking it, 123 automatically changed to 789.

    And this is probably related to the above. http://xenforo.com/community/members/brogan.521/?page=3#profile-post-4816

    Bug.png

    The user EntropiaPlanets has been renamed as SchmitzIT, yet it shows as the previous one.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    This is not a bug.
    The user name stored for post likes isn't dynamic, so it's whatever the user's name was at the time.

    You can see this post for example, which was liked by Abomination who is now Dean: http://xenforo.com/community/threads/pages.489/#post-5257

    The URL still resolves to the correct member though as it's done on the ID, not the name.
     
  3. Saeed

    Saeed Well-Known Member

    Thanks for clarifying that, Paul. :)
     

Share This Page