Not a bug Notes not appears in resources

Affected version
2.2

Abu Ghaith

Well-known member
When adding a note in the resources it does not appear.
Likewise, when you choose Page criteria for the note to appear in Resources and Sections, it disappears and does not appear in both.
 

Mike

XenForo developer
Staff member
I assume you're referring to the notices system. You'll need to give us the specific steps/criteria to allow us to reproduce the issue.

However, given what I think you're mentioning about the page criteria, your criteria is likely setup incorrectly. All criteria must match for a notice to be displayed. If you set a requirement that the page is within a resource category and (for example) within a node, these will never both match, so the notice wouldn't be displayed.
 

Abu Ghaith

Well-known member
I created a note and customized it with Page is within resources categories
And I created another note that appears on all pages
problem is that custom first note is disappearing
If you disable the second note, a custom note appears
 

Mike

XenForo developer
Staff member
I can't reproduce this.

Please be aware of which notice type you've selected. Specifically, if you select a "scrolling" notice, only one will be visible at a time and it will pan through them (like featured resources). If you select "block", each notice will be displayed in order.
 

Mike

XenForo developer
Staff member
Your video shows what I mentioned in the first post: you've setup criteria that is impossible to match.

For a notice to be displayed, every selected criteria must match. It is not possible for a page to both be in a resource category and in a node, thus the notice will never be displayed. If you want a notice displayed in each of those, you'd have to create separate notices (one with the resource category criteria, one with the node criteria).
 

spirogg

Active member
so why do we have the option like in the videos to select both ? node and resources for notes ? just wondering because you said it's not possible to have it in both? unless I misunderstood your writing ?
 
Top