Fixed Not working user_alert when creating an album

Bugfix

Member
Hello!
I just added an album with xengallery_album_permission view = followed.
I have another Testuser that follows the user who created the album.

This user got a red [1] that there is a new alert, but when I hover the alerts, it says "You have no new alerts.".
In the database I see the alert:
content_type = xengallery_album
content_id = album_id
action = share

Is there a Bug with XenGallery_AlertHandler_Album or am I missing something (or is it a misinterpretation)?
 

Chris D

XenForo developer
Staff member
Of course it is "127008" - the id of the album i just created
Well, that makes more sense, but I'm not sure why that wouldn't work :)

I have XenForo 1.5.2 and XenForo Media Gallery 1.1.1
I don't recall making any changes relating to this since 1.1.1 but I can confirm the tests I've just done locally worked fine.

I will try and reproduce it here. I will follow you and then share an album with you. Let me know the results of that.

Can you reproduce the problem consistently?
 

Chris D

XenForo developer
Staff member
If it still doesn't work, it may be worth trying with all add-ons disabled.

It might also be worth upgrading to a newer version (ideally the newest) just in case there has been fixes that are relevant to the issue.
 

Bugfix

Member
If it still doesn't work, it may be worth trying with all add-ons disabled.
*Puh* - this isn't easy since we have 20 active addons and we are already in the beta-phase.

It might also be worth upgrading to a newer version (ideally the newest) just in case there has been fixes that are relevant to the issue.
We will install the update after going live on 02.03.2016.
 

Chris D

XenForo developer
Staff member
I just got the alert from you and it worked.

I will try again on my site!
I think I may have stumbled across the bug you're reporting. You mentioned it was when creating an album, but I actually tested it on an existing album. We'll sort this, thanks for reporting.
 

Chris D

XenForo developer
Staff member
*Puh* - this isn't easy since we have 20 active addons and we are already in the beta-phase.
It's very easy, you just click a button to disable all add-ons (then just re-enable XFMG). Then you can click the button again to re-enable them all.

Not required, now, though.
 

Chris D

XenForo developer
Staff member
This is fixed now for the next release, thank you.

Workaround for the time being is to set the album permissions after the album has been created.
 
Top