• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not receiving alerts via ajax

Matthew Hawley

Well-known member
#1
For me alerts are not auto updating. I have to refresh the page to see new alerts. Is this happening to anyone? Would I have to have javascript enabled in my browser? Oh and this is happening on xenforo.com
 

James

Well-known member
#2
Alerts only auto-update when you perform an AJAX request, such as viewing the member card, liking a post or posting a quick reply.

Saving drafts also causes an alert check.
 
#6
Alerts only auto-update when you perform an AJAX request, such as viewing the member card, liking a post or posting a quick reply.

Saving drafts also causes an alert check.
Staying on topic, I'd love to know if anyone has implemented AJAX alert check to run constantly on background, say, every 15 seconds or so? If so, tips on how you implemented it are welcome ;-)

As we just switched to xenForo, the very first complaint was about alerts not being updated in real time -- requiring user to do something before the alerts are updated again.

Nevermind, as always, there seems to be an add-on available to do just that:

http://xenforo.com/community/resources/live-updates.274/

:)
 

Matthew Hawley

Well-known member
#7
Staying on topic, I'd love to know if anyone has implemented AJAX alert check to run constantly on background, say, every 15 seconds or so? If so, tips on how you implemented it are welcome ;-)

As we just switched to xenForo, the very first complaint was about alerts not being updated in real time -- requiring user to do something before the alerts are updated again.

Nevermind, as always, there seems to be an add-on available to do just that:

http://xenforo.com/community/resources/live-updates.274/

:)
That isnt what your looking for. That just puts in the favicon.