• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Lack of interest Not possible to include a template in a template email

lms

Well-known member
#1
I have noticed that it is not possible to include a template in a template email.
If I put <xen: include get an error and if I put <xen: require template is saved does not work.

I do not know if this is a bug or a not implementing feature.

If it is a not implementing feature, please, take this as a request to that effect, but if this is a bug, please a solution.

I created an addon and I tried to include a template to work with css style properties without success.

It would be great to work with style properties in email templates.


Salud2
 

Chris D

XenForo developer
Staff member
#2
I imagine this will get marked as "Won't Fix".

The template system and the e-mail template system are very different things. With that in mind, you can't include templates from one system in the other.

This is not a bug, but nor do I think your suggestion will be workable either.
 

lms

Well-known member
#3
Both template systems support <style type="text/css">. Public template system uses the <xen:include/require template/css> that comes to be a <style type="text/css">...</style>.

Why can not this be?

Salud2

Edit: The two systems are used with css.
 

Chris D

XenForo developer
Staff member
#4
Well, because they are two very different template systems.

You might be able to try:

<xen:require css="public:your_template.css" />

But again, I think it will fail for the same reasons.
 

lms

Well-known member
#5
And include email template.css with email templates? As it is, is mixing a public with a admin system. If this system could work well with the style properties, would be perfect.

Salud2
 

Mike

XenForo developer
Staff member
#6
As stated, they are very different systems so not all syntax is necessarily available everywhere. Moving to suggestions.