1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Not Latin Characters to Seo

Discussion in 'Resolved Bug Reports' started by mbt131, Jan 31, 2014.

  1. mbt131

    mbt131 Member

    I don't know this is a bug , but in my Turkish forum , convert to latin characters don't work right.It transforms to latin by missing one or two letter.I disabled this feature.Now if I copy links to elsewhere it is look like www.example.com/%C3%BCketiciye-%C3%96zel-%C3%87a%C4%9Fr%C4%B1 . It will be a handicap for seo ? What are your thoughts?
  2. seojoseph

    seojoseph Member

  3. mbt131

    mbt131 Member

    How can I fix this then?
  4. seojoseph

    seojoseph Member

    I don't know how come the URLs are messed up like that so I don't know how to fix it. Good luck though.
  5. Moshe1010

    Moshe1010 Well-Known Member

    Google still knows to read them. However, URLs, these days, have very minimal to non-existent impact on your SEO. It's all about content these days. I also had non-latin characters in my URLs and it gave me the same structure URLs (I guess the browser converts it to these ugly ones). Anyway, I've disabled it completely and my SEO improved regardless.
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You may wish to enable this to avoid those encoded characters in URLs:

    Admin CP -> Home -> Options -> Basic Board Information -> Romanize Titles in URLs

    Or disable this to rid yourself of titles in URLs thereby avoiding the issue:

    Admin CP -> Home -> Options -> Search Engine Optimisation (SEO) -> Include Content Title in URLs
  7. mbt131

    mbt131 Member

    Romanize titles doesn't work.It misses one or two letter.Such as : www.example.com/forum/éxamplé-forum if I romanize title and if it is contains non latin characters , it will be www.example.com/forum/xampl-forum . I don't know it is a bug.But in my Turkish forum , this is like that.
  8. Moshe1010

    Moshe1010 Well-Known Member

  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I tested that title (éxamplé-forum) in thread and forum titles with the romanize option enabled. The "é" was correctly replaced with "e". I can't reproduce your problem on my forum.

    Assuming no addons or route filters are involved here, you can submit a ticket with your forum information:


    We will take a look.
  10. AWS

    AWS Well-Known Member

    Are on a Windows Server with IIS by chance?
  11. mbt131

    mbt131 Member

    I just gave example.My actual problem doesn't with é . I have linux litespeed server using cloudflare.

    I enabled romanize titles again.There is the result ;

    My thread title : İnternet Girişimcisi Rehberi

    My link : http://www.tutarmi.net/forum/nternet-girisimcisi-rehberi.4/
    it should be :http://www.tutarmi.net/forum/internet-girisimcisi-rehberi.4/

    My thread title : Kültür-Sanat ve Hobi

    My link : http://www.tutarmi.net/forum/kueltuer-sanat-ve-hobi.21/
    it should be :http://www.tutarmi.net/forum/kultur-sanat-ve-hobi.21/

    These are what I detect soon.
  12. mbt131

    mbt131 Member

    Any solution?
  13. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That one I can confirm on my forum. The "İ" is stripped when the title is romanized.

    I will move this to bugs so the devs are aware. The romanize function is not 100% though.
  14. mbt131

    mbt131 Member

    Not just problem with "İ" , also with "Ü" "Ö" , many of Turkish letters.
  15. Mike

    Mike XenForo Developer Staff Member

    Romanization is language agnostic -- what is correct in your language is incorrect in another language. (Ü to "ue" would be correct in German, IIRC.) As such, this is expected. You would need to modify the romanization code to be specific to your language if you wanted to override the behavior.

    The İ being stripped is not expected though.
  16. mbt131

    mbt131 Member

    Ü letters corrent value is u , Ö's is o , Ç'is c . How can I modifiy romanization ? If non romanization letters have no handicap for seo , I can use with like that.But my link look likes example.com/%C5%9F%C3%B6rt/ , if I copy link from adress bar to elsewhere.
  17. Mike

    Mike XenForo Developer Staff Member

    I have resolved the lack of de-accenting for the dotted and dotless I in 1.3.

    All of the translations are done in library\Lgpl\utf8.php.
    soloarquitectura likes this.
  18. mbt131

    mbt131 Member

    I am using 1.2.4 , I am not thinking uprage 1.3 right now until beta is over.Can you share with me this file for 1.2.4?
  19. mbt131

    mbt131 Member

    Hey mike , Any solution to this bug for 1.2.4 yet?
  20. Jeremy

    Jeremy XenForo Moderator Staff Member

    You can download 1.3 and copy that file over.

Share This Page