• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Noobie Question?

#1
Hello, I'd like to ask a question which I cannot seem to find anywhere. I have a category on my site called "Main site forums" inside that I have one called "Site Announcements" and etc. I would like to submit thread and stuff inside that but cannot seem to figure it out for the life of me! It's a noobie question I know. Im sorry
 

Chris D

XenForo developer
Staff member
#2
Is Site Announcements a forum or a category?

You can only post threads in forum nodes.

The process of creating a thread should be identical to how you created this one.

If you cannot see the Create New Thread button in your forum then you should check the usergroup permissions.
 
#3
Is Site Announcements a forum or a category?

You can only post threads in forum nodes.

The process of creating a thread should be identical to how you created this one.

If you cannot see the Create New Thread button in your forum then you should check the usergroup permissions.
Its inside of a category and its a forum. When I click on the forum on the site, it just refreshes the page :/
 

craigiri

Well-known member
#4
If this is a new forum, you have to check your paths in the settings - as to where your board exists! As well, you have to check your .htaccess file if you are doing "pretty" URLs.
 

Chris D

XenForo developer
Staff member
#5
Sounds like it's a category, rather than a forum.

If you can post the URL I will check it out myself.
 

Ernest L. Defoe

Well-known member
#7
You don't have to edit anything in the .htaccess file or atleast I didn't and it works fine. I just enabled it.

Also I see what you are talking about now when clicking Site Announcements or any other node it refreshes the main page.
 
#8
You don't have to edit anything in the .htaccess file or atleast I didn't and it works fine. I just enabled it.

Also I see what you are talking about now when clicking Site Announcements or any other node it refreshes the main page.
What would you suggest I do? And when I enable friendly everytime I click a link, I get a 404 error page not found :/
 

craigiri

Well-known member
#10
Sure, you do have to have an .htaccess....but let's start with the first problem. Do you have the ACP-Options set up correctly - that's the part below. As to the .htacess, your server has to have mod_rewrite enabled and you must upload the htaccess.txt file that came with the XF download and change the name to .htaccess - and specify the base url as suggested inside the file.

Board URL
The primary URL to your board. Do not include a trailing "/" or "index.php". The URL should look similar to this: http://www.example.com/forum
 

craigiri

Well-known member
#11
Here are the contents of that htaccess.txt file

Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>
 
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default
 
<IfModule mod_rewrite.c>
    RewriteEngine On
 
    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo
 
    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
 
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 
#12
This is in my file. Where do I add my board?
Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
<IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>
 
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default
 
<IfModule mod_rewrite.c>
    RewriteEngine On
 
    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    RewriteBase /xenforo
 
    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
 
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 
#13
Here are the contents of that htaccess.txt file

Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>
 
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default
 
<IfModule mod_rewrite.c>
    RewriteEngine On
 
    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo
 
    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
 
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
Thank you, its working now
 
#14
Here are the contents of that htaccess.txt file

Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>
 
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default
 
<IfModule mod_rewrite.c>
    RewriteEngine On
 
    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo
 
    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
 
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
I think you earned yourself a spot in the forum mod if you'd like :) On my site:p If not, thanks anyways
 

Ernest L. Defoe

Well-known member
#15
Sure, you do have to have an .htaccess....but let's start with the first problem. Do you have the ACP-Options set up correctly - that's the part below. As to the .htacess, your server has to have mod_rewrite enabled and you must upload the htaccess.txt file that came with the XF download and change the name to .htaccess - and specify the base url as suggested inside the file.

Board URL
The primary URL to your board. Do not include a trailing "/" or "index.php". The URL should look similar to this: http://www.example.com/forum
I forgot that cause I took it for granted that my host had mod_rewrite installed and it wasn't an issue for me as I think he edited that file for me as well and all I did was enable it.