1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Noobie Question?

Discussion in 'XenForo Questions and Support' started by CodyMoores, Mar 7, 2013.

  1. CodyMoores

    CodyMoores Member

    Hello, I'd like to ask a question which I cannot seem to find anywhere. I have a category on my site called "Main site forums" inside that I have one called "Site Announcements" and etc. I would like to submit thread and stuff inside that but cannot seem to figure it out for the life of me! It's a noobie question I know. Im sorry
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    Is Site Announcements a forum or a category?

    You can only post threads in forum nodes.

    The process of creating a thread should be identical to how you created this one.

    If you cannot see the Create New Thread button in your forum then you should check the usergroup permissions.
     
  3. CodyMoores

    CodyMoores Member

    Its inside of a category and its a forum. When I click on the forum on the site, it just refreshes the page :/
     
  4. craigiri

    craigiri Well-Known Member

    If this is a new forum, you have to check your paths in the settings - as to where your board exists! As well, you have to check your .htaccess file if you are doing "pretty" URLs.
     
  5. Chris D

    Chris D XenForo Developer Staff Member

    Sounds like it's a category, rather than a forum.

    If you can post the URL I will check it out myself.
     
  6. CodyMoores

    CodyMoores Member

    www.hybridgaming.net and if I were going to configure the Friendly URLs, what would I edit in the .htaccess??
     
  7. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    You don't have to edit anything in the .htaccess file or atleast I didn't and it works fine. I just enabled it.

    Also I see what you are talking about now when clicking Site Announcements or any other node it refreshes the main page.
     
  8. CodyMoores

    CodyMoores Member

    What would you suggest I do? And when I enable friendly everytime I click a link, I get a 404 error page not found :/
     
  9. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    I registered on your site and sent ya a message in the shoutbox.
     
  10. craigiri

    craigiri Well-Known Member

    Sure, you do have to have an .htaccess....but let's start with the first problem. Do you have the ACP-Options set up correctly - that's the part below. As to the .htacess, your server has to have mod_rewrite enabled and you must upload the htaccess.txt file that came with the XF download and change the name to .htaccess - and specify the base url as suggested inside the file.

    Board URL
    The primary URL to your board. Do not include a trailing "/" or "index.php". The URL should look similar to this: http://www.example.com/forum
     
    Chris D likes this.
  11. craigiri

    craigiri Well-Known Member

    Here are the contents of that htaccess.txt file

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
     
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
     
    <IfModule mod_rewrite.c>
        RewriteEngine On
     
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
     
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
     
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
     
    CodyMoores likes this.
  12. CodyMoores

    CodyMoores Member

    This is in my file. Where do I add my board?
    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    <IfModule mod_security.c>
        SecFilterEngine Off
        SecFilterScanPOST Off
    </IfModule>
     
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
     
    <IfModule mod_rewrite.c>
        RewriteEngine On
     
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        RewriteBase /xenforo
     
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
     
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
     
  13. CodyMoores

    CodyMoores Member

    Thank you, its working now
     
  14. CodyMoores

    CodyMoores Member

    I think you earned yourself a spot in the forum mod if you'd like :) On my site:p If not, thanks anyways
     
  15. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    I forgot that cause I took it for granted that my host had mod_rewrite installed and it wasn't an issue for me as I think he edited that file for me as well and all I did was enable it.
     
  16. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    We got most of his issues figured out. More or less node permissions and a few things setup incorrectly.
     
  17. craigiri

    craigiri Well-Known Member

    Hah, I'm offloading all my work to MY site mods......looking for mods for my new drone site too!

    But I like helping people here like most of the others have helped me.
     
    CodyMoores likes this.
  18. CodyMoores

    CodyMoores Member

    Thanks anyways for your help my friend. I appreciate it greatly :) You too ernest!
     
  19. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    Not a problem. I have learned that most people on here are willing to help and some will go out of their way to do so.
     

Share This Page