• This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

Nodes As Tabs (with tab selection)

Status
Not open for further replies.

Morgain

Well-known member
I have made myself a very useful tab with links to the admin areas I use most often.
The clever people on this thread will work it out in a flash but for others like me not so savvy here is how I did it in a step by step dummies tutorial.

http://xenforo.com/community/threads/tutorial-admin-navbar-tab-dropdown-favorites.25712/

WHAT YOU CAN DO WITH IT
Create a tab to the Admin area, with a dropdown listing your favourite admin links.
admin-dropdown.png

HOW TO DO IT
# Create a Link Forum linking to the admincp and make it visible only to admins. It can show on the Node list to admins as well if you like. But its main purpose is to support a navbar tab.
# Create a list of links in a template this addon provides, to go under it. You don't need to understand code to do this!

Comments should go on the tutorial thread above so as not to clutter Jake's thread here.
 

Trekkan

Well-known member
Just got this error. Someone created a thread, then moved the thread to another forum and left a redirect in place. This is the error you get when clicking the link that should redirect to the new thread:

Invalid argument supplied for foreach()
  1. XenForo_Application::handlePhpError() in BookmarkPosts/Extend/ControllerPublic/Thread.php at line 19
  2. BookmarkPosts_Extend_ControllerPublic_Thread->actionIndex() in NodesAsTabs/ControllerPublic/Thread.php at line 44
  3. NodesAsTabs_ControllerPublic_Thread->actionIndex() in XenForo/FrontController.php at line 310
  4. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  5. XenForo_FrontController->run() in /home/nomad/public_html/forum/index.php at line 13
 

Jake Bunce

XenForo moderator
Staff member
Just got this error. Someone created a thread, then moved the thread to another forum and left a redirect in place. This is the error you get when clicking the link that should redirect to the new thread:
I just tested all manner of redirects on my forum and was unable to reproduce this error. It must be related to the other addon referenced in the error which is "BookmarkPosts". Try disabling that addon to test this.
 

Jake Bunce

XenForo moderator
Staff member
I upgraded from 110 to 110-3 and in my node list it still shows as Nodes As Tabs 1.1.0
What Brogan said. The "1.1.0" version string is the same for all three releases so far. I am using the version string to indicate what version of XF it was made for. But the version ID increases with each version. The latest is 101003.
 

Trekkan

Well-known member
I just tested all manner of redirects on my forum and was unable to reproduce this error. It must be related to the other addon referenced in the error which is "BookmarkPosts". Try disabling that addon to test this.
Thanks Jake, I didn't notice the other addon referenced. I'll check into that, although looks like I'll have to remove the mod as it's not supported anymore. Thanks for taking a look!
 

Stevebullman

Active member
Have installed this mod successfully. The possibilities seem endless for this with me. I have so many questions and dont know where to begin!

Heres a start though. If i for example have 5 categories each with 10 forums within, and I want to create 5 tabs so each of these essentially has their own page. Would it be possible to then delete the forums tab(which would display them all), but have the drop down options(mark read etc) show on each individual tab?
 

Jake Bunce

XenForo moderator
Staff member
Would it be possible to then delete the forums tab(which would display them all)...
You can remove it by editing this template:

Admin CP -> Appearance -> Templates -> navigation

But that will orphan any remaining forum pages that belong to that tab, such as the "What's New" page.

Another idea is to hide the tab only when it's not selected. See this post:

http://xenforo.com/community/threads/move-menu-items.20654/#post-263851

...but have the drop down options(mark read etc) show on each individual tab?
There is a configurable option for each node tab to show the "mark read" link. The other links will need to be manually added to a links template. If you want the same hard-coded links for all node tabs then you can edit the default links template to affect them all:

Admin CP -> Appearance -> Templates -> nat_linkstemplate

Otherwise you can specify a custom links template for each node tab:

Admin CP -> Applications -> Display Node Tree -> [click the node] -> Links Template
 

Stevebullman

Active member
You can remove it by editing this template:

Admin CP -> Appearance -> Templates -> navigation

But that will orphan any remaining forum pages that belong to that tab, such as the "What's New" page.

Another idea is to hide the tab only when it's not selected. See this post:

http://xenforo.com/community/threads/move-menu-items.20654/#post-263851
Thanks Jake, informative post.

Thats straight forward enough then. Losing the whats new button isnt an issue as im going to move this somewhere else anyway. Shall have a play!
 

Digital Doctor

Well-known member
This addon doesn't support threads as tabs, only nodes as tabs (hence the name :p). But if the thread is inside of a node tab then the thread will highlight that tab. With that in mind, you can create a forum as a child of the link forum, post the thread in that forum, then edit the link forum to go to that thread.

Link Forum (is tab, and links to thread)
- Forum (child of link forum)
- - Thread (posted inside of forum)

That will create the desired effect.

An alternative is to post your FAQ in a page node and make that into a tab. But that requires you to write HTML (for the contents of the page node).
Cool !
I like how the thread appears under the Tab.
http://theinfinityprogram.com/index.php?threads/faq-nsfaq.4275/

On that page ...
FAQ/NSFAQ
Discussion in 'Guide' started by Medora, Dec 19, 2011.

If you click on 'Guide' it takes you to the forum listing of the articles threads.

Is there a way to redirect the user away from the forum list ... back to the Tab ?
 

dwdmadmac

Active member
How would I stop a Specific Forum Tab from being displayed on the navigation?

I am using different "Styles" for each node tab, but I would like to hide "Node A Tab" when "Node B Tab" Is selected and then hide "Node B Tab" when "Node A Tab" is selected.

Edit:
Maybe a simple CSS fix?
 

Jake Bunce

XenForo moderator
Staff member
How would I stop a Specific Forum Tab from being displayed on the navigation?

I am using different "Styles" for each node tab, but I would like to hide "Node A Tab" when "Node B Tab" Is selected and then hide "Node B Tab" when "Node A Tab" is selected.

Edit:
Maybe a simple CSS fix?
You can hide the tab when it's not selected. See this post:

http://xenforo.com/community/threads/move-menu-items.20654/#post-263851

There is also a configurable option for each node tab to check permissions for the tab. In that way you can hide tabs if a user doesn't have permission. I don't know if that is what you want.
 

infinite.loop

Active member
I like this add-on very much!
Something I'd like to be able to do is to put the forum tabs into a separate line above (or below) the normal navbar (Home - Forums - Members -Help).

That would be great to make them stick out more when used as Forum Catgories as we do currently with a vb mod -> http://forum.team-mediaportal.com

We will migrate to XF soon'ish. :D
 
Status
Not open for further replies.
Top