1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 No reply box, no avatars, no upload button

Discussion in 'Troubleshooting and Problems' started by gavpeds, Aug 31, 2016.

  1. gavpeds

    gavpeds Active Member

    Someone must have come across this before.
    I am having several problems that only seem to be showing up on iOS mobiles.
    Thread reply box and post text fields don't show. Refresh the page they come back then refresh again their gone. Upload button does the same and user avatars do the same.

    It's only iOS don't know if it is a js or cache or both issue. Can't check console for iOS device as don't have a Mac to connect phone and use web instructor.

    Anyone any ideas at all this is happening on the default theme as well. windowcleaningforums.co.uk

    I did have DB cache and defer js installed all seemed to start after i removed them.

    Some users say it's fine but after a Cache and data clear it happens. Some say it's there but after a chache and data clear it's gone. It seems to be hit and miss the only constant is that it is iOS phones using safari

    Also getting this error but files are in the correct place and as stated I am still having these issues on default theme.

    image.png
     
    Last edited: Sep 1, 2016
  2. gavpeds

    gavpeds Active Member

    Guess no one then :(
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    I don't have an Apple device so can't check.

    Does the same thing happen on this forum?

    If not, it's likely going to be an issue with your style or an add-on.
     
  4. gavpeds

    gavpeds Active Member

    Just our forum. It happens on the default theme as well if I disable all add-on it still happens.
    In addition to the some users are now reporting getting "security error please refresh the page" When trying to upload an image.
     
  5. Martok

    Martok Well-Known Member

    I've checked your site using an iPad and can see the issue with the disappearing avatars at times (I can't check the rest as I don't have a login, if you provide a test one I can check with that). I checked this with both Chrome and Safari on iPad.

    I can't replicate the avatar issue on either my Android tablet, nor on my Mac using Chrome or Safari.

    I have noticed when looking at the console on both Chrome (which you can do from PC) and Safari that you sometimes get some error messages related to adverts:

    upload_2016-9-2_8-42-45.png

    (note that I also use Google Ads and have an HTTP website but I never get these mixed content errors)

    The console on Safari (which you could check out if you downloaded Safari for Windows) does show a lot of CSS errors but I don't know if this is just Safari being pernickety as I don't get them in the Chrome console.

    upload_2016-9-2_9-7-35.png



    As for the js from the Bliss style, that is there. However, I was able to directly access this via the web browser which you shouldn't be able to (really you should get a 403 Forbidden, which I get when trying to access the js from my Audentio style, so you might want to look into this).


    upload_2016-9-2_8-57-46.png


    You say that the issues persist with the default style. Is the default style completely unedited (so not customisations whatsover and therefore no adverts)?

    Also, have you checked with the authors of the add-ons you removed (DB Cache and Defer JS) if there's anything that needs to be done when they are uninstalled (such as rebuilding caches, rebuilding master data)?
     
  6. gavpeds

    gavpeds Active Member

    Yes the issues only seem to be on ios phones specifically.

    Yeah i noticed these but from reading seems shouldnt be a problem as some ads are serving using https but our site is not https. I could be wrong however.

    No i dont get these in chrome but seeing as most of the issues seem to be ios related and seem to be css/js related this could be the problem

    Hmm not sure why this is the permissions are as they should be. Bliss folder is 755 js files are 644.

    I have and they say just uninstalling and removing files should be fine. How do i rebuild master data? I have rebuilt caches etc to no effect.


    Thanks so much for your reply and looking in to this.
     
  7. Martok

    Martok Well-Known Member

    That'll be iOS devices, as I tested on an iPad (I was also confirming that it didn't seem to be an issue on a Mac).

    As I said, my site is http and I serve https ads but I don't get any of these errors.

    In the same way that you upgrade XenForo - go to URL/install (and login if not already). As there is no upgrade to do, there will be a rebuild master data option which you can run. I don't know if it will fix this issue but it might be worth a try.
     
  8. gavpeds

    gavpeds Active Member

    Have rebuilt master data with no effect some users are now reporting in addition to everything else that if the reply box actually does show when they go to submit the post is says unspecified error. More and more errors seem to be cropping up. :mad::mad::mad::cry::cry::cry:
     
  9. Chris D

    Chris D XenForo Developer Staff Member

    I was going to register and test but I can't:

    IMG_5702.PNG

    That error usually suggests some level of caching being involved.

    This could be related.

    You mention specifically in your first post a "cache and data clear". I would actually look at disabling this caching completely in the first instance.

    If the issues go away then it relates to the cache configuration and you should seek support from whoever provides that mechanism.
     
  10. gavpeds

    gavpeds Active Member

    I am on php7 with Redis cache which Mattw setup. I have tried flushing redis and also turned the redis addon off to no effect. What i meant was user browser cache clear.

    It certainly seems to be some kind of cache issue i just don't know what.
     
  11. Chris D

    Chris D XenForo Developer Staff Member

    The other cause of that registration error above could be outdated templates.

    It might be worth running on a completely unedited, default XF style for a bit to rule out all of this being style related and JS issues.
     
  12. gavpeds

    gavpeds Active Member

    Ok I have disabled all Addons. And set default theme which has no modified templates. Still issues.

    No avatars. No logo. But again as stated as you browse around sometimes they show sometimes they don't.

    Test User account
    User and pass xftest

    image.png image.png image.png
     
  13. Chris D

    Chris D XenForo Developer Staff Member

    I'll plug in my iPhone to my Mac with Safari and see if I can make some sense with this via the dev console.
     
    Last edited: Sep 2, 2016
  14. gavpeds

    gavpeds Active Member

    No worries as mention the majority of these issues seems to be on iPhone/iPad.
     
  15. Chris D

    Chris D XenForo Developer Staff Member

    I've been browsing around the forum for the last 10 minutes logged into your test account with my iPhone and I'm not experiencing any issues at all.

    Everything loads, all the avatars and the quick reply editor always loads. Is there anything specific that would trigger this?

    How many people have actually reported this?
     
  16. gavpeds

    gavpeds Active Member

    There doesn't seem to be anything that triggers it. I have had about 10-15 user report so far. I was not experiencing this issue on my iphone for the first few days of users reporting it and was not able to replicate then suddenly yesterday i started to see the issues.
     
  17. Martok

    Martok Well-Known Member

    I've just tried again on my iPad as a guest (after cleaning browser caches) on both Chrome and Safari and I'm still seeing avatars and the XenForo logo sometimes not loading. Refreshing sometimes brings them back and also sometimes they disappear again.
     
    gavpeds likes this.
  18. gavpeds

    gavpeds Active Member

    Yes exactly what i am seeing and other users.
     
  19. Chris D

    Chris D XenForo Developer Staff Member

    I still can't reproduce it on my phone (iOS 10).

    I've just tried it on the iOS Simulator (iOS 9.3) and I am experiencing some images not loading.

    According to the Safari dev console the images are 404, not found. Yet if you take the URL of the image and open it in a new tab then it loads fine.
     
  20. gavpeds

    gavpeds Active Member

    Yeah exactly I don't know what's going on its really weird. Same with the js errors from the theme saying they were not there but are.
     

Share This Page