XF 2.2 No preview shown for any link after import from SMF

Lorthirk

New member
Hello all,

I imported an old SMF forum to Xenforo. Everything works great, but I noticed that old posts with an embedded media (YouTube, DailyMotion, etc.) are shown as links instead that showing the embedded video. If I then edit that post and just save it without changing anything, the video is correctly shown. Is there a way to do such an operation in bulk for the whole forum? Maybe something in the Rebuild Cache section? I already tried "Rebuild post embed metadata" with the "Attachments" checkbox selected, but nothing changed
 

Lorthirk

New member
Well, actually I see that any link that was previously posted is not shown its preview, even regular links, not only media. So my issue is even more pressing now. Is there a way to regenerate all the previews?
 

beerForo

Well-known member
You probably need to inspect the code and replace it with this tool:
 

beerForo

Well-known member
I believe so. He answered in a PM instead of here so I'll post it. It resaves the post and removes the last edited text. So I am assuming every post has the "History" link appear and it shows in the logs in the post and in admin. So yes it changes the updated date. Personally I'd be a little hesitant to run an add-on that resaved every post as there is no way to quality check the results for large sites.

You can use the above tool however quite easily. If you post in the discussion thread for it members can help you with the replacement code. You can wrap your unfurl and media tags around your links and get them working.

EDIT: He updated the add-on description.
 
Last edited:

djbaxter

Well-known member
I believe so. He answered in a PM instead of here so I'll post it. It resaves the post and removes the last edited text. So I am assuming every post has the "History" link appear and it shows in the logs in the post and in admin. So yes it changes the updated date. Personally I'd be a little hesitant to run an add-on that resaved every post as there is no way to quality check the results for large sites.

You can use the above tool however quite easily. If you post in the discussion thread for it members can help you with the replacement code. You can wrap your unfurl and media tags around your links and get them working.

EDIT: He updated the add-on description.
Does it change the update date?

It only changes the last edited date, not the message posted date.

@AndyB can you confirm this is correct?
 
Top