1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 No Post New Thread Icon

Discussion in 'XenForo Questions and Support' started by denisx04, Aug 23, 2013.

  1. denisx04

    denisx04 Active Member

    Basically sections that DO NOT have subforums have the "post new thread" icon, but for sections that have subforums the "post new thread" icon does not appear until you click on a subforum WITHIN that section.

    Example

    Regular Noforum Section ---- has new post icon

    Section 1 --------- has no new post thread icon
    -- subforum has the post new thread icon

    Is it meant to be that way? for my sake I hope not :p
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    I'm not sure what you are talking about? Are you putting the sub forums in a category or an actual forum?
     
  3. denisx04

    denisx04 Active Member

    Here is an example

    http://www.enixorigin.com/forum/forums/member-area.23/

    Please log in using

    Username: Test
    password: test

    Or you can click any section that has subforums, you'll notice that it doesn't have a "Post New Thread" icon until you click on a subforum OR a forum that doesn't have any subforums.


    Or you can use an example here,

    http://xenforo.com/community/forums/xenforo-suggestions.18/

    That section has a subforum, but when you click on xenforo suggestions that has the "post new thread" icon as well as the subforum.

    On mine only the subforum has a post new thread icon.
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    What are the permissions for the forum containing sub forums? Can you analyze the permissions for yourself?
     
  5. denisx04

    denisx04 Active Member

    I did, made sure everything was allowed for my usergroup. Still no luck
     
  6. Martok

    Martok Well-Known Member

    Could this be a style issue?

    The permissions to create a new thread in a forum with sub forums seem to exist. If you add /create-thread to the end of the URL of one of these forums it brings up the Create Thread page, something which it wouldn't do (I assume) if you didn't have the right permissions.
     
  7. Mike

    Mike XenForo Developer Staff Member

    I agree on it being a style issue. The button is in a different position if there are sub-forums so that also fits.
     
  8. denisx04

    denisx04 Active Member

    Talked to the designer he said its not a style issue, so I have no clue where to go from here.
     
  9. Mike

    Mike XenForo Developer Staff Member

    Set up a default style and disable all add-ons. Can you still confirm it?
     
  10. denisx04

    denisx04 Active Member

    Yeah it works perfectly on xenforo default skin, but on my main skin it does not. The weird thing is that while our main fixed skin doesn't have the "post new thread"icon in nodes that have subnodes, the regular fluid of the same skin that we do not use has them in all the nodes. I tried erasing all the Extra.css codes and no luck, tried disabling all addons, no luck. So the default xenforo is perfect, the custom fluid skin is perfect, but the custom fixed is the only one having the issue.


    EDIT:FIXED!
     
    Last edited: Aug 23, 2013

Share This Page