1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 No Ban Link for Certain Users

Discussion in 'Troubleshooting and Problems' started by Steve F, Apr 25, 2016.

  1. Steve F

    Steve F Well-Known Member

    We have 2 users that do not have a ban link, either on the member card or profile.

    These users were imported from an old XF forum we had and on there they were moderators. On the current forum they are not moderators but are in 2 groups, Registered and the other is simply a group to give access to certain nodes.

    Is it a possible bug?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It certainly sounds like the moderator flag is still set.

    What happens if you promote them to moderator and then demote?
    Does the ban option then appear?
     
  3. Steve F

    Steve F Well-Known Member

    I thought of doing the same but didn't because I figured it may be useful to leave it in case someone wanted to look deeper into it.

    Can certainly try if needed.
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    As Paul says, it could be the is_moderator flag, which is in the xf_user table.

    Is it set to 1 for these two users?

    I assume those users don't appear in the xf_moderator table?
     
  5. Steve F

    Steve F Well-Known Member

    Yes, they are set to 1 for is_moderator. They are not in the xf_moderator table.
     
  6. Steve F

    Steve F Well-Known Member

    Also, adding the user as a moderator then removing them corrects the issue.
     
  7. Chris D

    Chris D XenForo Developer Staff Member

    Ok and this was an XF to XF import?

    When were they actually removed as moderators? Before the import or after? Or did something go wrong in between?
     
  8. Steve F

    Steve F Well-Known Member

    It's been quite a while so I'll need to investigate. I'm almost certain they were still moderators on the db that was being imported to the current db. I have the old db setup on my localhost but I'm out right now so will need to check it later.
     
    Chris D likes this.

Share This Page