1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

nginx is killing me ;_;

Discussion in 'Server Configuration and Hosting' started by Sway, Feb 27, 2013.

  1. Sway

    Sway Active Member

    I am moving my website to a new server, and am having problems with php-fpm/php5-fpm...

    I know my current setup is correct but i am confused as to why i am seeing these permission denied, and file does not exist errors while setting things up.

    Last thing i need to get done before i can start migrating from server to server. I must get php-fpm working..

    Error/log shows this: 2013/02/26 20:48:47 [crit] 13614#0: *3 connect() to unix:/usr/sbin/php5-fpm.sock failed (2: No such file or directory) while connecting to upstream, client: xx.xxx.xxx.x, server: domain.com, request: "GET / HTTP/1.0", upstream: "fastcgi://unix:/usr/sbin/php5-fpm.sock:", host: "domain.com", referrer: "http://domain.com/index.php"

    I used whereis php5-fpm, and got this:

    root@ICC:~# whereis php5-fpm
    php5-fpm: /usr/sbin/php5-fpm /usr/share/man/man8/php5-fpm.8.gz

    If you need any more information i will post here. I am pretty confused ;_;
  2. digitalpoint

    digitalpoint Well-Known Member

    Is PHP-FPM running? Looks to me like it's not running...
    HWS likes this.
  3. Sway

    Sway Active Member

    It wasn't LOL!

    I also had to change the configuration file for php-fpm. I got this working ;D
    HWS likes this.

Share This Page