1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Need help with redirect from vB4.2 with vBSEO

Discussion in 'Installation, Upgrade, and Import Support' started by Renegade, Mar 9, 2013.

  1. Renegade

    Renegade Well-Known Member

    The co-admin that I was depending on to set this up ditched me last minute and I need to setup the redirects myself.

    So far I have gone to this page and uploaded by VBSEO settings file ->http://tools.geekpoint.net/xfseo/

    This is the output



    Can someone please spoon feed me this one time so that I am able to set this up.
    Also if I am using VBSEO then do I need to use the following anywhere?
    http://xenforo.com/community/threads/redirection-scripts-for-vbulletin-3-x.5030/
    http://xenforo.com/community/resources/vbulletin-4-x-url-redirection.120/
     
  2. Renegade

    Renegade Well-Known Member

    Alright the redirects are setup now it is taking to the correct thread. However the pages within a thread are still not working. A page X from VB URL is taking to the page 1 of XF URL.
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Those redirect scripts don't do page numbers. Is your XF forum showing the same number of posts per page as your vB forum? Otherwise the page numbers won't match up so it would not be appropriate to redirect them. But if you want to include page numbers in the redirects then edit the showthread.php file and add the red code:

    Code:
    if ($input['t'])
    {
    	if ($newId = $importModel->mapThreadId($input['t']))
    	{
    		$target = XenForo_Link::buildPublicLink('canonical:threads', array('thread_id' => $newId), array('page' => max(1, $inputHandler->filterSingle('page', XenForo_Input::UINT))));
    	}
    }
    
    Untested, but that should work with your rewrite rules.
     
    Moddis and Neso like this.
  4. Renegade

    Renegade Well-Known Member

    Thanks for your reply. :)

    Yes the number of posts per page is same in both the places. Are you saying that the redirects in Kier's script are not supposed to honor page numbers. Won't that be counter productive for visitors coming from the search engine?

    I tried your method but it does not take me to the correct page. Still the first page of the thread. :(

     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The home page or page 1 of the thread?
     
  6. Renegade

    Renegade Well-Known Member

    You quoted me before I could correct that. :p Yes the first page of the thread.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Then I need to take a look. Can you give me FTP access?
     
  8. Renegade

    Renegade Well-Known Member

    I tried changing the directory but it isnt working now. It seems that the 301 redirect file from Kier is not passing the directoy path in the URL. When I insert it manully in the translated URL, the link works.
     
  9. Renegade

    Renegade Well-Known Member

    Anyone who can help me with the directory changing and page redirects?
     
  10. DRE

    DRE Well-Known Member

    Chillax breh, Jake got this. Give him some time. :cool:
     
  11. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Sooo... he had everything setup correctly, but his browser had cached the redirect so he wasn't seeing the changes take effect. I often have this problem with Firefox, so I use Chrome to test redirects and changes to .htaccess files.
     
    Renegade likes this.
  12. Renegade

    Renegade Well-Known Member

    It was really frustrating. How insignificant things can send you on a wild goose chase. o_O

    Thanks for all the help Jake :coffee:
     
  13. Moddis

    Moddis Active Member

    Just tested and the thread pagination fix works fine.

    Thanks.
     

Share This Page