1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Mysqli statement execute error - preventing me from doing many operations

Discussion in 'Troubleshooting and Problems' started by jflory7, Jun 5, 2014.

  1. jflory7

    jflory7 Active Member

    Hello XenForo forums,

    Today, I encountered a strange issue with my XenForo installation.

    I was trying to rebuild my user cache and ran into this error. Thinking it was related to an add-on I was using, I tried disabling the add-on and received this error. I then tried disabling other add-ons and received similar results.

    To say the least, I am a little confused. To begin, I've done a little diagnostic information on my end. Thinking there may be a corrupt MySQL table, I tried checking, repairing, and optimizing my MySQL database for XenForo by following this guide. This is the exact command I ran:
    Code:
    # mysqlcheck -u root -p --auto-repair -c -o xenforo
    However, this did not seem to solve the problem.

    The next thing I tried was restarting the MySQL server, but that also did not help any.

    I am quite confused… any help would be very appreciated!

    - jflory7
     
  2. Mike

    Mike XenForo Developer Staff Member

    It looks like you may have some invalid/corrupt data in the DB. It's likely related to the secondary_group_ids column in xf_user. You'd really need to find the invalid value and remove it. You might be able to get away with identifying the user and then editing them via the control panel.

    Have you imported? If so, from what and using what importer?
     
  3. jflory7

    jflory7 Active Member

    I haven't ever imported any data – this is a fresh installation.

    As for the invalid data, I use this add-on by @KoolKrafter which adds a new column called 'uuid' to the xf_user table. This is probably the issue, isn't it?
     
  4. jflory7

    jflory7 Active Member

    I tried running this command in my XenForo MySQL database.
    Code:
    mysql> ALTER TABLE 'xf_user' DROP 'uuid';
    After that, I tried doing some of the tasks from before to the same result.
    Any ideas?
     
  5. Mike

    Mike XenForo Developer Staff Member

    Please submit a ticket with phpMyAdmin and ACP access details and I'll look into it.
     
  6. jflory7

    jflory7 Active Member

    Ticket submitted. Thanks.
     
  7. KoolKrafter

    KoolKrafter Member

    Sorry for the delayed response, but I don't see why my extra column would cause that problem.. did you get it fixed?
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    The problem was due to corrupt data in the secondary_group_ids in the database.

    An add-on was most likely the culprit although it wasn't confirmed which one.
     
    jflory7 likes this.
  9. KoolKrafter

    KoolKrafter Member

    Okay. I'm glad it could be resolved :)
     
  10. jflory7

    jflory7 Active Member

    The problem was a Minecraft plugin that interacted with the XenForo MySQL database, and it turns out that it forgot to properly add a comma for the secondary user IDs. The problem was in no way related to @KoolKrafter's add-on or any add-on that I've used from the XF Resources section. As of the writing of this post, the developer has posted a fix for the plugin as well, so hopefully this will not happen to any other users.

    If the issue ever occurs for any others, the plugin's name is "CommunityBridge".
     

Share This Page