• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Mysqli statement execute error -1 from Storage engine

#1
Hi ,
I am getting this error recently,
Any help please..
Thanks in advance :)

i made a template edit, to add this link in navigation bar,

i doubted in this, so pointing this,

"http://domain.com/forum/find-new/posts?recent=1


Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Got error -1 from storage engine - library/Zend/Db/Statement/Mysqli.php:214
Generated By: Unknown Account, Yesterday at 8:43 PM

#0 /home/user/public_html/forum/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)

#1 /home/user/public_html/forum/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)

#2 /home/user/public_html/forum/library/XenForo/Model.php(219): Zend_Db_Adapter_Abstract->query('\n\t\t\t\tSELECT thr...', Array, 2)

#3 /home/user/public_html/forum/library/XenForo/Model/Thread.php(550): XenForo_Model->fetchAllKeyed('\n\t\t\t\tSELECT thr...', 'thread_id')

#4 /home/user/public_html/forum/library/XenForo/ControllerPublic/FindNew.php(163): XenForo_Model_Thread->getThreads(Array, Array)

#5 /home/user/public_html/forum/library/XenForo/ControllerPublic/FindNew.php(35): XenForo_ControllerPublic_FindNew->findNewPosts()

#6 /home/user/public_html/forum/library/Waindigo/Thumbnails/Extend/XenForo/ControllerPublic/FindNew.php(16): XenForo_ControllerPublic_FindNew->actionPosts()

#7 /home/user/public_html/forum/library/XenForo/FrontController.php(347): Waindigo_Thumbnails_Extend_XenForo_ControllerPublic_FindNew->actionPosts()

#8 /home/user/public_html/forum/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))

#9 /home/user/public_html/forum/index.php(13): XenForo_FrontController->run()
#10 {main}

Request State

array(3) {
["url"] => string(54) "http://domain.com/forum/find-new/842/posts?page=8"
["_GET"] => array(1) {
["page"] => string(1) "8"
}
["_POST"] => array(0) {
}
 

Jake Bunce

XenForo moderator
Staff member
#2
That error code is not specific except to say that it's some problem with the storage engine. You might be out of disk space or memory.

I suggest you contact your web host or server admin about this. If you manage your own server then make sure your disks / partitions are not full (including /tmp). Make sure /tmp is writable.
 
#3
oh..!!! ok Jake :)
Normally this errors are showing up , around 8PM Indian Time, during our peak hours,
I am using Godaddy shared hosting!!
Thanks for reply..!! let me ask them about this!!