1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 MySQLi Error max_allowed_packet

Discussion in 'Troubleshooting and Problems' started by bluemartian, Jul 22, 2012.

  1. bluemartian

    bluemartian Member

    Hi, I'm trying to install a style that has a child style. The main style framework imports just fine but when I try to import the child XML, I get the error shown below. I contacted my webhost and they kindly bumped the "max_allowed_packet" value from 16M to 32M but the error persists (in fact, it happens sooner than it did at 16M). I've installed other styles with child styles before without a problem. Any suggestions or advice? Thanks!
    Mysqli statement execute error : Got a packet bigger than 'max_allowed_packet' bytes
    Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    Zend_Db_Adapter_Abstract->query() in XenForo/Model/DataRegistry.php at line 164
    XenForo_Model_DataRegistry->set() in XenForo/Model/Style.php at line 434
    XenForo_Model_Style->rebuildStyleCache() in XenForo/DataWriter/Style.php at line 171
    XenForo_DataWriter_Style->_rebuildCache() in XenForo/DataWriter/Style.php at line 162
    XenForo_DataWriter_Style->_postSave() in TMS/DataWriter/Style.php at line 19
    TMS_DataWriter_Style->_postSave() in XenForo/DataWriter.php at line 1385
    XenForo_DataWriter->save() in XenForo/Model/StyleProperty.php at line 699
    XenForo_Model_StyleProperty->updatePropertyCacheInStyle() in XenForo/Model/StyleProperty.php at line 632
    XenForo_Model_StyleProperty->rebuildPropertyCacheInStyleAndChildren() in XenForo/Model/StyleProperty.php at line 2316
    XenForo_Model_StyleProperty->importStylePropertiesFromArray() in XenForo/Model/StyleProperty.php at line 2187
    XenForo_Model_StyleProperty->importStylePropertyXml() in XenForo/Model/Style.php at line 533
    XenForo_Model_Style->importStyleXml() in TMS/Model/Style.php at line 45
    TMS_Model_Style->importStyleXml() in XenForo/ControllerAdmin/Style.php at line 181
    XenForo_ControllerAdmin_Style->actionImport() in XenForo/FrontController.php at line 310
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in /home/[removed]/public_html/[removed].com/admin.php at line 13
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You can increase the limit even more. Having a large "max_allowed_packet" doesn't hurt anything.

    How many styles do you have installed? An excessive number of styles might explain the usage here.
  3. bluemartian

    bluemartian Member

    Hi Jake...

    I'm hoping my webhost is willing to do another increase but that is up to them - I've got a request in on my trouble ticket with them. I have 4 styles installed, including the default style. This one would be #5.

    I was a bit surprised that the import seemed to go for a while before crapping out with the error when the value was at 16M, but then got the error immediately after my webhost increased the value to 32M. I would have thought the import would have at least gotten a little farther along if not completed.
  4. bluemartian

    bluemartian Member

    Just FYI. My webhost made another tweak on the server (not sure what) and the import was successful. They said "max_allowed_packet" was still at the new value of 32M, so I suspect the first tech who dealt with my ticket had not done something when he tried to adjust it that the second tech did do. Either way, I'm good to go at last. Thanks for your help.

Share This Page