1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Mysqli Error

Discussion in 'XenForo Questions and Support' started by Giverny, Aug 22, 2016.

  1. Giverny

    Giverny Member

    Hope I'm posting in the right place here! Basically, my forum had some database issues on Friday, leading our tech guy to try and rebuild the forum's master data. On doing this, he encountered the following error and is now unsure what queries he needs to run in order to fix the problem.

    Mysqli statement execute error : Duplicate entry '0-ajaxProgress' for key 'definition_style_id_property_name'
    Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
    Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1638
    XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1627
    XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1419
    XenForo_DataWriter->save() in XenForo/Model/StyleProperty.php at line 2400
    XenForo_Model_StyleProperty->importStylePropertiesFromArray() in XenForo/Model/StyleProperty.php at line 2312
    XenForo_Model_StyleProperty->importStylePropertyXml() in XenForo/Model/StyleProperty.php at line 2245
    XenForo_Model_StyleProperty->importStylePropertyDevelopmentXml() in XenForo/Deferred/ImportMasterData.php at line 26
    XenForo_Deferred_ImportMasterData->execute() in XenForo/Deferred/Atomic.php at line 66
    XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 295
    XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 429
    XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 355
    XenForo_Model_Deferred->runByUniqueKey() in XenForo/Install/Controller/Abstract.php at line 34
    XenForo_Install_Controller_Abstract->_manualDeferredRunner() in XenForo/Install/Controller/Upgrade.php at line 221
    XenForo_Install_Controller_Upgrade->actionRunDeferred() in XenForo/FrontController.php at line 351
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in D:/Websites/Diabetes.co.uk/forum/install/index.php at line 18
    If anyone's able to offer any tips on fixing the issue, it'd be much appreciated. Thanks!
  2. Brogan

    Brogan XenForo Moderator Staff Member

    This is now being handled via ticket.
  3. Giverny

    Giverny Member

Share This Page