1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mysqli database errors?

Discussion in 'Troubleshooting and Problems' started by Jungalist81, Jul 30, 2012.

  1. Jungalist81

    Jungalist81 Member

    Hello everyone,

    I recently purchased a xenforo license. I was able to install it correctly but whenever I browse through the admin CP, it would start to lag then this would popup:

    Mysqli statement execute error : Prepared statement needs to be re-prepared
    1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    3. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 753
    4. Zend_Db_Adapter_Abstract->fetchRow() in XenForo/Model/User.php at line 345
    5. XenForo_Model_User->getUserById() in XenForo/Model/User.php at line 710
    6. XenForo_Model_User->getVisitingUserById() in XenForo/Visitor.php at line 383
    7. XenForo_Visitor::setup() in XenForo/Session.php at line 296
    8. XenForo_Session::startAdminSession() in XenForo/ControllerAdmin/Abstract.php at line 48
    9. XenForo_ControllerAdmin_Abstract->_setupSession() in XenForo/Controller.php at line 298
    10. XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 309
    11. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    12. XenForo_FrontController->run() in /home/skyedenm/public_html/admin.php at line 13
    I was reading and searching around for an answer and I couldn't find a resolution. Here are some more information:
    • Which version of XenForo you are running
      I just bought XenForo less than a week ago and chose the latest version.
    • A list of all add-ons you have installed
      I have no add-ons I have installed.
    • Any outdated templates or phrases
      No I do not know what that means lol.
    • Custom styles in use
      I changed some of the colours around but changed it back to default.
    • Confirmation that all add-ons and styles are compatible with the XenForo version you are running
    • Whether the problem occurs in a specific browser, or more than one browser
      This occurs in any browser.
    • Whether the issue is experienced by all users or just some
      This is experienced by other members as well who have access to the admin CP.
    • Browser add-ons in use, e.g. Adblock Plus, NoScript, etc.
      I disabled adblock Plus and the error still occurs.
    • Any changes which were made prior to the problem occurring
      Nothing really except change 1 single colour and created a new forum category.
    • Details of any errors in the ACP server error log
      I do not know what the ACP server error log is (starting to google now)
    • Steps to be taken to reproduce the problem and whether it can consistently be reproduced
      Install xenforo completely then go through the Admin CP and wait for it to lag then that error will pop up.
    • Confirmation whether the problem can be reproduced here on XenForo.com
      I am not sure.
    P.S I tried doing the rebuild cache thing and it would work but afterwards the Admin CP would get slow again.
    Edit: I was able to goto the server error log and I have at least 5 pages of the same error:
    "Mysqli statement execute error : Prepared statement needs to be re-prepared
    2 minutes ago - library/Zend/Db/Statement/Mysqli.php:214"
    Sorry english not my 1st language

  2. Chris D

    Chris D XenForo Developer Staff Member

    This is likely to be a server configuration problem.

    An old post I just found by one of the developers says the cause isn't specific and is often resolved by restarting your MySQL Server.

    However, aside from that, this helpful post by Jake Bunce might help:


    You are likely to either need root access to your server or to contact your hosts.
    Jake Bunce likes this.
  3. estranged

    estranged Well-Known Member

    I also had this problem once and restarting the mysql service fixed the issue for me.
  4. Ingenious

    Ingenious Well-Known Member

    I get this error from time to time (see this thread).

Share This Page