• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Mysql errors

ALMUSA

Active member
#1
Im getting a lot of Mysql errors these days and here are some examples.

I took these issues to the host and i got this email back from them

check this with the script vendor and let me know if they want us to make any particualr changes within the domain.
public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
public_html/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
public_html/library/XenForo/DataWriter.php(1624): Zend_Db_Adapter_Abstract->insert('xf_post', Array)
public_html/library/XenForo/DataWriter.php(1613): XenForo_DataWriter->_insert()
public_html/library/XenForo/DataWriter.php(1405): XenForo_DataWriter->_save()
public_html/library/XenForo/DataWriter/Discussion.php(477): XenForo_DataWriter->save()
public_html/library/XenForo/DataWriter/Discussion.php(426): XenForo_DataWriter_Discussion->_saveFirstMessageDw()
public_html/library/XenForo/DataWriter.php(1409): XenForo_DataWriter_Discussion->_postSave()
public_html/library/XenForo/ControllerPublic/Forum.php(745): XenForo_DataWriter->save()
public_html/library/Tinhte/XenTag/XenForo/ControllerPublic/Forum.php(28): XenForo_ControllerPublic_Forum->actionAddThread()
public_html/library/XenForo/FrontController.php(347): Tinhte_XenTag_XenForo_ControllerPublic_Forum->actionAddThread()
public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
public_html/index.php(13): XenForo_FrontController->run()
#14 {main}









------------------------------------



public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
public_html/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
public_html/library/XenForo/DataWriter.php(1624): Zend_Db_Adapter_Abstract->insert('xf_post', Array)
public_html/library/XenForo/DataWriter.php(1613): XenForo_DataWriter->_insert()
public_html/library/XenForo/DataWriter.php(1405): XenForo_DataWriter->_save()
public_html/library/XenForo/ControllerPublic/Thread.php(557): XenForo_DataWriter->save()
public_html/library/DoublePost/ControllerPublic/Thread.php(35): XenForo_ControllerPublic_Thread->actionAddReply()
public_html/library/XenForo/FrontController.php(347): DoublePost_ControllerPublic_Thread->actionAddReply()
public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
public_html/index.php(13): XenForo_FrontController->run()
#11 {main}


/public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
public_html/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
public_html/library/XenForo/DataWriter.php(1624): Zend_Db_Adapter_Abstract->insert('xf_post', Array)
public_html/library/XenForo/DataWriter.php(1613): XenForo_DataWriter->_insert()
public_html/library/XenForo/DataWriter.php(1405): XenForo_DataWriter->_save()
public_html/library/XenForo/DataWriter/Discussion.php(477): XenForo_DataWriter->save()
public_html/library/XenForo/DataWriter/Discussion.php(426): XenForo_DataWriter_Discussion->_saveFirstMessageDw()
public_html/library/XenForo/DataWriter.php(1409): XenForo_DataWriter_Discussion->_postSave()
public_html/library/XenForo/ControllerPublic/Forum.php(745): XenForo_DataWriter->save()
public_html/library/Tinhte/XenTag/XenForo/ControllerPublic/Forum.php(28): XenForo_ControllerPublic_Forum->actionAddThread()
public_html/library/XenForo/FrontController.php(347): Tinhte_XenTag_XenForo_ControllerPublic_Forum->actionAddThread()
public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
public_html/index.php(13): XenForo_FrontController->run()
#14 {main}
----------------------------
/public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/almusaf/public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
public_html/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
public_html/library/XenForo/DataWriter.php(1624): Zend_Db_Adapter_Abstract->insert('xf_post', Array)
public_html/library/XenForo/DataWriter.php(1613): XenForo_DataWriter->_insert()
public_html/library/XenForo/DataWriter.php(1405): XenForo_DataWriter->_save()
public_html/library/XenForo/DataWriter/Discussion.php(477): XenForo_DataWriter->save()
public_html/library/XenForo/DataWriter/Discussion.php(426): XenForo_DataWriter_Discussion->_saveFirstMessageDw()
public_html/library/XenForo/DataWriter.php(1409): XenForo_DataWriter_Discussion->_postSave()
public_html/library/XenForo/ControllerPublic/Forum.php(745): XenForo_DataWriter->save()
public_html/library/Tinhte/XenTag/XenForo/ControllerPublic/Forum.php(28): XenForo_ControllerPublic_Forum->actionAddThread()
public_html/library/XenForo/FrontController.php(347): Tinhte_XenTag_XenForo_ControllerPublic_Forum->actionAddThread()
public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
public_html/index.php(13): XenForo_FrontController->run()
#14 {main}

.......the list goes on.

What could be causing those errors and what is the way to fix them.
 

ALMUSA

Active member
#3
Sorry about that.

Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Incorrect string value: '\xBB Bill...' for column 'message' at row 1 - library/Zend/Db/Statement/Mysqli.php:214

Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Incorrect string value: '\xAB Brea...' for column 'message' at row 1 - library/Zend/Db/Statement/Mysqli.php:214
 

Mike

XenForo developer
Staff member
#4
These are almost certainly caused by an add-on (one that translates links to their respective titles).