mysql error question

pk698

Active member
Anyone know what I'm doing wrong?

Warning: require_once(/home/pk1998/public_html/includes/defines/path.php) [function.require-once]: failed to open stream: No such file or directory in /home/pk1998/public_html/w/includes/setup.php on line 32

Fatal error: require_once() [function.require]: Failed opening required '/home/pk1998/public_html/includes/defines/path.php' (include_path='.:/usr/lib/php') in /home/pk1998/public_html/w/includes/setup.php on line 32


If I have my script on the main public_html directory, it works fine. Currently I have it setup in a sub-directory for testing (which causes the error).
 

Brandon_R

Guest
Did you rename the setup file to setup.php? I know some software gives you the file in file.php.txt so you can open it etc.
 

pk698

Active member
No, it was already setup.php. Seems my path is wrong but I'm not sure where to change it.
 

pk698

Active member
It was a script I had someone code for me eons ago - when woolly mammoths roamed the earth. Here is the code in the path.php:

<?
define('DEFAULT_CAMPUS','3');
define('HTTP_SERVER', 'http://'.$_SERVER['SERVER_NAME'].'');
define('DIRECTORY', '/');
define('FILENAME_DEFAULT', 'index.php');
define('ICON_BULLET_PATH', HTTP_SERVER.DIRECTORY.'/images/icons/bullet/');
define('ADVANCED_SEARCH_DEFAULT_OPERATOR', 'and');

?>
and in setup.php file, this code:

// Figure out where we're at
$docroot = $_SERVER['DOCUMENT_ROOT'];
// check if document-root ends with a '/'
if (substr($docroot,strlen($docroot)-1,1) != "/") {
$docroot = $docroot . "/";
And their installation instructions:

### everylist doc ###########

1. Set the database on includes/functions/database.php/
2. Run the everylist_sql.txt
3. Insert the pk user (so it will get #1 id, update the status id to 3 and privilege id to 2)
 
Top