1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My Xenforo forum has become slow

Discussion in 'Troubleshooting and Problems' started by KidCactus, Apr 11, 2012.

  1. KidCactus

    KidCactus Member

    What exactly is the Xenforo software doing when I see the progress bar in the top-right corner? As of late, my forum has become quite unresponsive at times, more or less completely random, and most of the time it is when that progress bar is visible. For example, when clicking Alerts, it sometimes takes a really long time befor they are shown. And sometimes just browsing the forum takes forever, with up to 20 seconds before the page you clicked loads -- again, completely random.

    I've talked to my hosting company about this, but since it's all random, they can't see any general issues that would cause this. They have even switched my account over to a different platform with better performance, but I still have the same issue. The database shouldn't be the problem, when I do queries I get very rapid replies.

    Anyone got any ideas?

    My forum can be found at: http://wearegamers.se
  2. CyclingTribe

    CyclingTribe Well-Known Member

    As a guest I seem to be able to browse threads okay. Are you seeing the problems if you use the site as a guest?

    Do you have any add-ons installed? Have you tried temporarily disabling them all to see if it fixes the problem? Maybe turn them on one by one to see if one in particular causes the problems you are seeing.

    Shaun :D
  3. mrGTB

    mrGTB Well-Known Member

    That was my thought, could be a rouge add-on if you use them causing it.
  4. Digital Doctor

    Digital Doctor Well-Known Member

    I was surfing around and I thought it was "OK speed" most of the time, then fast for a while, and the I clicked on a measly Help menu item and it took forever. Did the same thing again ... and I clicked on a thread and it seemed to be stuck on "waiting for the server".

    Hosting issue ?
  5. CyclingTribe

    CyclingTribe Well-Known Member

    To the OP: You don't have a low SQL connection limit by any chance do you?
  6. KidCactus

    KidCactus Member

    I have quite a few add-ons installed, I will try disabling them and see if that makes a difference.

    This is exactly what I'm talking about; all of a sudden something random just takes forever. My host can't see any issues at all, unfortunately. And as I said, I've even been switched over to a faster platform.

    That I do not know, is there any easy way I can check that? I do not have access to the SQL server, only the PHPmyadmin.
  7. CyclingTribe

    CyclingTribe Well-Known Member

    Yes. Login to phpMyAdmin and on the homepage click the link "Show MySQL system variables". In the list look for "max connections" and let us know what the value is?

    Shaun :D
  8. KidCactus

    KidCactus Member

    max connections 1500

    Doing a simple query like select * from xf_thread takes about 0.0013 seconds.

    I can also add that I get this same random slow behavior in the Admin Control Panel. And I've now also tried disabling the add-ons, but there is no difference at all (as it seems right now, at least).

    Edit: It really feels like my Xenforo installation is broken in some way — now I'm uninstalling all the addons, and it takes forever, sometimes with several timeouts where I have to refresh the page. I'm installing a fresh copy on another domain (same host) now, and with an empty database at least, everything is butter smooth. I'll see what happens when I import my DB.
    CyclingTribe likes this.
  9. craigiri

    craigiri Well-Known Member

    Don't rule out problems from elsewhere - that is, between you and where the XF installation is! This includes router and switch issues, ISP issues, etc.

    Try some traceroutes from other areas to see if there are any slowdowns.
  10. KidCactus

    KidCactus Member

    Ok, so now a fresh installation of Xenforo is running on another domain, the database is imported, no addons installed... and all is running lightning fast again.

    I will run it like this for a week or so, then move back to the original domain, run it there for a while and if everything works fine, I will try one addon at a time. I really hope it doesn't get messed up again, even though this reinstallation has gone very smooth. My users did have to get a new password, though, not sure why.
    CyclingTribe likes this.
  11. KidCactus

    KidCactus Member

    Ok, moved back to my original domain, but now nobody can change avatar. This is the error:

    rename(/the path to my site/wearegamers.se/public_html/data/avatars/l/0/2.jpg) [function.rename]: Operation not permitted
    XenForo_Application::handlePhpError() in XenForo/Model/Avatar.php at line 342
    XenForo_Model_Avatar->_writeAvatar() in XenForo/Model/Avatar.php at line 206
    XenForo_Model_Avatar->applyAvatar() in XenForo/Model/Avatar.php at line 69
    XenForo_Model_Avatar->uploadAvatar() in XenForo/ControllerPublic/Account.php at line 482
    XenForo_ControllerPublic_Account->actionAvatarUpload() in XenForo/FrontController.php at line 310
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in /the path to my site/wearegamers.se/public_html/index.php at line 13

    Maybe some access rights that are incorrect...?
  12. CyclingTribe

    CyclingTribe Well-Known Member

    Have you checked permissions for: /the path to my site/wearegamers.se/public_html/data/avatars

    ... and it's sub-directories?
  13. CyclingTribe

    CyclingTribe Well-Known Member

    If you need to make it (and it's subs writeable):

    # cd /the path to my site/wearegamers.se/public_html/data/
    # chmod -R 0777 avatars

    Check the /data/ directory too.
    Digital Doctor likes this.
  14. mrGTB

    mrGTB Well-Known Member

    If you've changed domain, have you checked things like the config.php file to see if it still shows old domain in it that needs changing to new one. Also, did you move files from one server to another, if you did chances are you've lost your chmod permission on file and folder move (now getting given server default chmod permissions instead). Which won't be 777.

    You could also download your database and, open in text editor and do a quick search for old domain, just to be sure it's not still listed anywhere in it.
  15. KidCactus

    KidCactus Member

    Thanks for the ideas, but this was due to something messed up on my account at my host:


Share This Page