1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Moving to a new Domain

Discussion in 'General XenForo Discussion and Feedback' started by Mark Thompson, Feb 13, 2013.

  1. Mark Thompson

    Mark Thompson Member

    I am moving my forum to a new domain on the same server.

    I thought the process was as simple as:

    Upload all the files from the old site
    Change the URL under options

    But when i tested that today i get the error below on the new site (same for login etc)

    I suspect it's something simple.

    As I am deleting the old files how do i deal with having 2 installs of the same licence (1 database) while testing for a few days?


    Not Found

    The requested URL /Forum/account/ was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Not Found

    The requested URL /Forum/logout/ was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
     
  2. Morgain

    Morgain Well-Known Member

    You are permitted to run a test install off your one licence. Providing only one is actively in use by members you're fine.
    When you get the new one working if your board has had input from members you'll need to re-import.
     
  3. Mark Thompson

    Mark Thompson Member

    Thanks...



    The errors i am having are due to friendly links ,so I've modified the .htaccess using the details from the old site but still have the issues

    This is what i have copied across...

    Options +FollowSymLinks

    # AddHandler application/x-httpd-php .php .html .htm
    #AddType application/x-httpd-php .php .html
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_URI} !^/(Forum|Forum/.*)$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    RewriteCond %{HTTP_HOST} ^newdomain\.com$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.newdomain\.com$
     
  4. Mark Thompson

    Mark Thompson Member

    I've now fixed this issue with a new .htaccess file containing the following



    #<IfModule mod_rewrite.c>
    RewriteEngine On

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    #</IfModule>
     

Share This Page