• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Moving threads, painfully slow with Enhanced search?

PVO_Dave

Active member
#1
Anyone else having issues? We recently had Elastic search upgraded due to some stability issues / using up too much memory.

Now with it enabled, moving threads takes way too long, approx 5 minutes or longer to move 20 threads!

Anything I can get my host to check etc..? Moving threads is very fast when ES is disabled.

Thanks,
Dave.
 

Slavik

XenForo moderator
Staff member
#2
Anyone else having issues? We recently had Elastic search upgraded due to some stability issues / using up too much memory.

Now with it enabled, moving threads takes way too long, approx 5 minutes or longer to move 20 threads!

Anything I can get my host to check etc..? Moving threads is very fast when ES is disabled.

Thanks,
Dave.
Very parculiar behavior,

How many posts does you forum have and how much memory is assigned to ElasticSearch?
 

PVO_Dave

Active member
#3
Hi Slavik,

Since a restart of ES and a cache rebuild it's now performing normally again!

thread / post wise:

Discussions:
283,961​
Messages:
2,085,337​


I'll have to find out about the memory allocated
 

Slavik

XenForo moderator
Staff member
#5
Hi Slavik,

Memory settings are as follows:

set.default.ES_MIN_MEM=768
set.default.ES_MAX_MEM=3072
You are runing an older version of ES by the looks of it, the new versions only apply one setitng which is the max heap size.

If the issue is resolved, it should be fine, but if it re-occurs update to the latest versions of JRE and ES.