XF 2.0 More clicking when editing post

Valter

Active member
In XF 1.x, when editing post, I was able to click 'Clear last edit information' checkbox to check both options - 'Edit silently' and 'Clear last edit information'.

In XF 2.x, when editing post, I need to first check 'Edit silently' to be able to check 'Clear last edit information'.

Can you change this to work in XF 1.x style so we can avoid additional click here? Thanks. :)
 

Martok

Well-known member
In XF 1.x, when editing post, I was able to click 'Clear last edit information' checkbox to check both options - 'Edit silently' and 'Clear last edit information'.
Presumably this is a template edit that you have made on your forum. This isn't the default behaviour, you need to tick both boxes separately on XF 1.x (I've tested this on 2 sites).
 

Brogan

XenForo moderator
Staff member
s isn't the default behaviour, you need to tick both boxes separately on XF 1.x (I've tested this on 2 sites).
Actually, I can do it some of the time, but not all the time.

I haven't worked out what causes the change in behaviour but it is definitely possible.
 

mjp

Well-known member
In XF 1.x, when editing post, I was able to click 'Clear last edit information' checkbox to check both options - 'Edit silently' and 'Clear last edit information'.

In XF 2.x, when editing post, I need to first check 'Edit silently' to be able to check 'Clear last edit information'.
I've noticed the same thing, and I'm 87.4% sure I didn't make a template edit to achieve that function.

If it was intentional feature of the 1.x versions, it would be nice to implement it in 2.x.

I edit a lot of user posts, so it's a lot of clicking, and not to play the disability card, but I have been medically classified as Ultra-Lazy, so I'd appreciate some relief.
 

imno007

Well-known member
I've just tested it with several threads and can confirm that this was the case with all of them. I've done no template edits.
 

Mike

XenForo developer
Staff member
This is very unlikely to change. The behavior before involved clicking on an input that was disabled and that actually activating that control, which is rather unexpected and really doesn't explicitly demonstrate why it's disabled (that it depends on another behavior, the parent checkbox, being active).

Any change here would likely need to come from custom JS/an add-on.
 
Top