• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Moderator question

#1
I have a user that was a moderator when we moved to xenforo but now I need to remove him. On his edit user page in the admincp it says "moderator" at the top, but he does not show up in my list of moderators. What am I missing?
 

Brogan

XenForo moderator
Staff member
#2
If the member isn't listed in the moderators list, they aren't a moderator: admin.php?moderators/

Is it just the title which is showing as Moderator?
If so, that will be from a user group or custom title.
 
#3
If the member isn't listed in the moderators list, they aren't a moderator: admin.php?moderators/

Is it just the title which is showing as Moderator?
If so, that will be from a user group or custom title.
This is what I'm seeing right now, it shows moderator on his page but he doesn't show up in the list of moderators.

1.PNG
2.PNG
 

Mike

XenForo developer
Staff member
#4
Based on the date, I'm assuming there was an import involved or potentially something related to an add-on. Simplest approach may be to make him a moderator again and then remove him as a mod.
 
#5
Based on the date, I'm assuming there was an import involved or potentially something related to an add-on. Simplest approach may be to make him a moderator again and then remove him as a mod.
How do I do that? The option to make him a mod isn't there, just an admin.
 
#8
I also had this issue, but I resolved it by finding his user id in the group_relations in the database and removed those entries. (edit: relating to the group in question)
Under his username in the database it did not show the secondary group as moderator.
I am gathering this is why the interface has this oddity.

We migrated to Xen from phpbb.