Fixed Moderator Permissions



It seems it takes 2 saves of the Moderator permission list in order to apply the values to a new Moderator.

To see what I mean follow these steps:
  1. Create a new user named ‘test’ for example and then make them a Moderator (forum based NOT super) via the users->moderators->create_new_moderator
  2. Before saving the Moderator form check the box for ‘Quick check all’ and either leave them as a registered member or add them to the ‘moderating’ usergroup (but ensure that the Forum Moderator Permissions are set to ‘Not set’ which is the default for a new install).
  3. After saving the form sign in as your new moderator. You will notice that the only new post option is the ‘Spam’ button. ‘Delete’ and ‘Edit’ are not available.
  4. In order to actually provide these extra moderation options you will have to go back to the Moderator form users->moderators->your_user. Here you will need to uncheck one option (your choice) and then save the form. Simply saving a second time without un-checking one value will not change anything.
  5. You will notice that only now does your ‘test’ user actually has proper moderating permissions.
  • This issue does not affect newly created ‘Super’ moderators.
  • This is also not an issue if the newly created moderator is assigned a secondary usergroup (such as ‘moderating’) which already has the forum permissions set to ‘Allow’.
With all due respect to those about to reply here, please do so ONLY if you have actually tried this yourself. Please do not speculate as to what you think is happening but limit responses to actual facts. Thank you.


XenForo moderator
Staff member
I reported something similar to Mike and Kier quite a while ago.

I can't remember whether I created a bug report for it or not.