MG 2.2 Mirrored media > moving threads

nicodak

Well-known member
Hello,

If a thread in a forum whose images are not mirrored has an image and that thread is moved to a mirrored forum the image shouldn't be automatically mirrored?
It seems that is not ALWAYS the case...

Is there cases where mirroring is not done ?
Thanks
 
Solution
Ok, I have to stand corrected. We do have code to handle syncing the mirror state when a thread is moved. Though for it to be random, that would be peculiar.

nicodak

Well-known member
Though you can run the “Sync attachment media mirroring“ rebuild if needed.
Yes indeed, but since there are a certain number of mirrored images that I do not want to appear in the gallery, they have to be manually deleted each time and it is a bit tedious. Is there a chance that the images will be mirrored when moving the discussion in a future update?
 

nicodak

Well-known member
@Chris D it's weird because sometimes images are mirrored after a thread move, sometimes not.
I had the case where even adding an image in a post of the moved thread did not cause it to be added in the mirrored media category. On the other hand, adding a photo in a new message in this discussion will trigger the mirroring.

I can't find at the moment what makes the difference, is it random or is it a setting somewhere? yet all forums and media categories have the same settings.

An idea ?
 

Chris D

XenForo developer
Staff member
Ok, I have to stand corrected. We do have code to handle syncing the mirror state when a thread is moved. Though for it to be random, that would be peculiar.
 
Solution

nicodak

Well-known member
Thanks, this seems to me more in accordance with what I have been able to observe.

I have a really bad connection here so maybe this may be affecting the sync. When I say bad connection it really is, sometimes I get 12KB/s in DL, I must be crazy to manage a forum with such a connection ...
 
Top