Resource icon

Minecraft UUID/Name Change Handler 0.1.0

No permission to download

chris_61

Member
Hmm when i go to register i seem to be getting "A server error occurred. Please try again later."

This is what it shows in the ADMIN CP:

Code:
Error Info
ErrorException: file_get_contents(https://api.mojang.com/profiles/minecraft): failed to open stream: HTTP request failed! HTTP/1.1 429 429 - library\mcUUID\Model\UUID.php:65
Generated By: Unknown Account, 2 minutes ago
Stack Trace
#0 [internal function]: XenForo_Application::handlePhpError(2, 'file_get_conten...', 'C:\xampp\domain...', 65, Array)
#1 C:\xampp\domains\MCBuffalo.com\htdocs\library\mcUUID\Model\UUID.php(65): file_get_contents('https://api.moj...', false, Resource id #111)
#2 C:\xampp\domains\MCBuffalo.com\htdocs\library\mcUUID\DataWriter\User.php(26): mcUUID_Model_UUID->getUUIDByName('LindseyPayton')
#3 C:\xampp\domains\MCBuffalo.com\htdocs\library\XenForo\DataWriter.php(1446): mcUUID_DataWriter_User->_preSave()
#4 C:\xampp\domains\MCBuffalo.com\htdocs\library\XenForo\ControllerPublic\Register.php(404): XenForo_DataWriter->preSave()
#5 C:\xampp\domains\MCBuffalo.com\htdocs\library\Jrahmy\Minecraft\ControllerPublic\Register.php(66): XenForo_ControllerPublic_Register->actionRegister()
#6 C:\xampp\domains\MCBuffalo.com\htdocs\library\XenForo\FrontController.php(347): Jrahmy\Minecraft\ControllerPublic\Register->actionRegister()
#7 C:\xampp\domains\MCBuffalo.com\htdocs\library\XenForo\FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#8 C:\xampp\domains\MCBuffalo.com\htdocs\index.php(13): XenForo_FrontController->run()
#9 {main}
Request State
array(3) {
  ["url"] => string(38) "http://mcbuffalo.com/register/register"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(15) {
    ["username"] => string(0) ""
    ["54e98a248da55f1637d0acc0627cc4a8"] => string(13) "LindseyPayton"
    ["6ebe2b778ad681c4512fc7f6a51170cc"] => string(21) "contact@mcbuffalo.com"
    ["de1f959371b4da69fb26ed2ddf7630d2"] => string(6) "female"
    ["dob_month"] => string(1) "1"
    ["dob_day"] => string(2) "14"
    ["dob_year"] => string(4) "1992"
    ["ab2bdb573afd89e7f31b1feb6787d787"] => array(1) {
      ["ytiwzgqzzjuynzg"] => string(0) ""
    }
    ["custom_fields_shown"] => array(1) {
      [0] => string(15) "ytiwzgqzzjuynzg"
    }
    ["4a65aa9a6cbf978c216ba4ee921b3d31"] => string(13) "Europe/London"
    ["recaptcha_challenge_field"] => string(292) "03AHJ_VutBzyVBlpB_rkK8o56T48pcFkebsDtyf1X_VYk_7ef0_0h3M7lGD8qa2NSRPg8MOdU_IXN6o_giJUBqzqaWylY9jnWAUWgu-DDQWnymrC5YkQ2bBdaBWHmf7HoMpnDZeJsG1RXfFzzpPqsffmfiHa1xc_POt__LL9Kg31816ZVNz9FtyAI_o7gxdfSNuUf6AgyHd5h3mosfX6N9LKS9unaqTYcxuUiB89bAWw4OvIFex8mKAuBuYeGHITEKmd70yfFNfiI_lHwZemFtLbBdw49R0UHj9g"
    ["recaptcha_response_field"] => string(5) "37807"
    ["agree"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["reg_key"] => string(32) "a20dd3f52784fa692522a910e2301d98"
  }
 
Last edited:

Pawned

Member
Is it possible to get this to pull through the full UUID (with the -'s in it) with this addon? Currently it doesn't include the -'s which I require as I am using CommunityBridge to sync Minecraft and Forum ranks but CommunityBridge looks for the full UUID including -'s so I am having to stick with syncing using username instead of UUID at the moment.
 

jflory7

Active member
Is it possible to get this to pull through the full UUID (with the -'s in it) with this addon? Currently it doesn't include the -'s which I require as I am using CommunityBridge to sync Minecraft and Forum ranks but CommunityBridge looks for the full UUID including -'s so I am having to stick with syncing using username instead of UUID at the moment.
I think it would be more appropriate to contact the developer of CommunityBridge to fix how his program implements UUID detection for XenForo.
 

Pawned

Member
I think it would be more appropriate to contact the developer of CommunityBridge to fix how his program implements UUID detection for XenForo.
All CommunityBridge does it read the value from whatever field in the database you select. But I did more digging and it's actually the permissions system that uses the formatted UUID for players, not CommunityBridge. It seems most plugins in Minecraft use the fully formatted UUID as opposed to the trimmed UUID.

I managed to modify this add-on anyway to add in the hyphens to the UUID it retrieves before inserting into the database (and manually increased the columns max character limit from 32 to 36 to enable this to work) so problem solved.
 

jflory7

Active member
All CommunityBridge does it read the value from whatever field in the database you select. But I did more digging and it's actually the permissions system that uses the formatted UUID for players, not CommunityBridge. It seems most plugins in Minecraft use the fully formatted UUID as opposed to the trimmed UUID.

I managed to modify this add-on anyway to add in the hyphens to the UUID it retrieves before inserting into the database (and manually increased the columns max character limit from 32 to 36 to enable this to work) so problem solved.
Hmm, I see. What permissions plugin?
 

Kainzo

Active member
I have 80,000 users in my database, pretty sure there's no way this regenerate UUID function will ever work unless heavily queued.

Is @KoolKrafter around anymore?
 

KoolKrafter

Member
I have 80,000 users in my database, pretty sure there's no way this regenerate UUID function will ever work unless heavily queued.

Is @KoolKrafter around anymore?
I don't really check here at all. I don't really play any Minecraft anymore.

Yes, I think you're right. I did start working on a new version of that function that staggers the regeneration however I don't think I'm going to have the time to sort it out any time soon. In the summer I will probably release another version of this add-on which sorts that out - but I wouldn't expect too much.
 

chris_61

Member
I updated Xenforo and reinstalled some addons now i get:

The following error occurred:
The requested page could not be found.

when i try click update username via the front end of the back end under tools > regen. Any help would be appreciated.
 

Spanner_Man

Member
I did start working on a new version of that function that staggers the regeneration however I don't think I'm going to have the time to sort it out any time soon. In the summer I will probably release another version of this add-on which sorts that out - but I wouldn't expect too much.
Any update/progress on this?
 

KoolKrafter

Member
Any update/progress on this?
Due to school exams, I don't think I'm going to have any time to work on this. I've lost all of my interest in Minecraft really and I haven't had any donations (my sole source of motivation on this project sadly) in a long time now.

If I find some time I might come back to this but it seems unlikely. Feel free to modify it yourself though!
 
Top