XF 2.2 Members can't see PWA install option

Andy.N

Well-known member
I installed beta 1 on my site at https://quantnet.com and was able to install the PWA on my Android and Chrome browser laptop.
2 members said that they don't see the option to install PWA.
Can anyone here let me know if the option is available for you?
Thanks
 

Brogan

XenForo moderator
Staff member
Looks like you have to be on an Android device and using chrome?
Not necessarily.

Additionally, as with push notifications, these features are only available on devices and browsers that fully support PWAs. Would you care to take a guess as to what the most notable exceptions might be? As you may have suspected, once again Safari on macOS and any iOS-based browsers are the culprits due to Apple's ongoing failure to implement industry standards. While Safari on both macOS and iOS does support graceful offline handling, it does not support installation or badging (more on that below) at this time.
 
I have this same issue. Admin console says requirements are met and things should be good to go but no option to install appears. I gave it about a week and still nothing. Cleared cache on all browsers and still nothing. Do I need to do anything to make this happen? Yes this is on android and windows.
 

Mike

XenForo developer
Staff member
Looking at your site, I don't see the manifest in the template source, so it looks to me like you have outdated templates (and thus don't have the 2.2 changes that are expected).
 
Looking at your site, I don't see the manifest in the template source, so it looks to me like you have outdated templates (and thus don't have the 2.2 changes that are expected).
So is that something I can fix or is it simply a matter of waiting for the style author to update the style to 2.2?
 
Top