1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Members can view thumbnail but not full image

Discussion in 'Media Gallery Resolved Bugs' started by Glockie, May 7, 2015.

  1. Glockie

    Glockie Well-Known Member

    Hello,
    I've recently found a situation and an odd occurrence really.

    As per title, members can view thumbnail but not the full image.
    We have quite strict album privacy, so user A has set his permissions to share his album with people HE follows..
    User B is followed by A, so B can see his albums.. Great.

    However, the user can see the thumbnail but upon clicking on the image, he is presented with - Error You do not have permission to view media within this album.

    I have set the permissions per usergroup but I don't quite understand why the user can see the thumbnail but not the full size image.
    As admin I have checked the permissions set and it's 'who can add' and 'who can view' all set to people you follow.
    I have encountered this before but now I am at a loss... :confused:
    I would appreciate some pointers, if you could.

    Thank you very much.
     
    Last edited: May 7, 2015
  2. Chris D

    Chris D XenForo Developer Staff Member

    Where do the thumbnails actually appear? Which pages? Or in the media block?

    What version of XFMG are you running?
     
  3. Glockie

    Glockie Well-Known Member

    Hi Chris,
    Thank you for taking the time to reply.
    It's weird as the person has now followed the other person, and now they work.
    Even though the setting is for people he follows only..

    The appeared in the media page. And also if I selected - his account > media > see the thumbnail but can't see full image when clicking on the link.
    We're using 1.0.4
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    I'm not sure if it's totally the same issue, but I have just found a bug related to the follow privacy setting. I need to look at it in more detail so I will fix the bug I have just found and attempt to recreate the situation you describe above.
     
    Glockie likes this.
  5. Glockie

    Glockie Well-Known Member

    Okay thank you.
    Indeed it seems that if you share with followers, they can see thumbs but not click on them.
     
  6. Chris D

    Chris D XenForo Developer Staff Member

    I have fixed the bug I have found, which, although I couldn't reproduce your exact issue, I can see how it might happen and the changes I've made today should hopefully prevent it from happening in the future.
     
    Glockie likes this.
  7. Glockie

    Glockie Well-Known Member

    Ahh fantastic.
    Okay thank you for letting me know, I look forward to it :)
     

Share This Page