1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RM 1.1 Max File Size Upload problem

Discussion in 'Resource Manager Support' started by Lucian Chirvase, Aug 8, 2015.

  1. Hello,
    I am experiencing a problem when trying to upload a file into RM.

    In RM options the file limit is set to 300 Mb.
    In accepted file types, 7z is included.
    In php.ini the upload_max_filesize is 400 Mb

    Yet, when trying to upload my file (a .7z archive, of about 200 Mb) I get this error:
    [​IMG]

    Help, pls ?

    PS: it works as expected with other (smaller) files.
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    What is the post_max_size value in php.ini?
     
    Lucian Chirvase likes this.
  3. Since writing the OP, they were both (upload_max_filesize and post_max_size) raised at 512M ! (from earlier 400M)
    It still doesn't work.. :|
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    Did you restart the web server after making the changes?

    Another thing to check is if they are being overridden elsewhere.

    Do you see the changes effective if you look at yoursite.com/admin.php?tools/phpinfo ?
     
    Lucian Chirvase likes this.
  5. The modifications were done by the hosting provider so I assume they did restart

    Where should one look for this ? (it's a simple website, with only XF installed)

    Yes.

    There was some advancement meanwhile (I'm online with hosting support for the last 3h almost..):
    Now the file is uploaded, and then the "processing phase" begins - the error comes after about 4 minutes. Earlier this morning it was showing up faster.

    Also, they (hosting support) say they've managed to do it (upload the file).
     
  6. I see in the php there is a limit called "max_input_time" with a value of 240 (I assume seconds, so 4 minutes).
    Could this be linked to the problem ?
     
  7. Chris D

    Chris D XenForo Developer Staff Member

    Yes that could also be related along with max_execution_time
     
    Lucian Chirvase likes this.
  8. Chris D

    Chris D XenForo Developer Staff Member

    Also on the MySQL side:

    max_allowed_packet
    max_packet_size
    wait_timeout
     
    Lucian Chirvase likes this.
  9. max_execution_time is at 350.

    Progress since last reply:
    Could the name of the file be a problem ? How does RM/XF treat this ? I'll explain.

    The file I am trying to upload is called testfile_V0.91+fix.7z and has 200 Mb. It doesn't work.
    When I've changed the name of the file to simply testfile.7z, it worked.
    Could the engine be troubled by the "." in name and confuses the extension ? (yet, the error message is not something like file type now allowed..).
     
  10. Chris D

    Chris D XenForo Developer Staff Member

    It should usually be ok because it would see the extension as .7z (it should work backwards to establish the extension is valid).

    It's possible the file name could be causing a problem but I would need to test that.
     
    Lucian Chirvase likes this.
  11. Update.

    Problem solved after 3hr with hosting support.
    It looks like some Mod_Security rules were whitelisted; I wouldn't know to say which ones though.
    Hope this could help somebody else at some point.

    @Chris D thank you for your replies, it helped steering the investigations in the right direction.

    PS: it works no matter the name of the file to be uploaded.
     
    Chris D likes this.

Share This Page