1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Manual user upgrade doesn't add additional usergroup

Discussion in 'XenForo Questions and Support' started by Tim Jay, Sep 2, 2014.

  1. Tim Jay

    Tim Jay Active Member

    I have a user upgrade where 1 Additional User Group is supposed to apply after purchase.

    When I manually upgrade a user, it's not adding the usergroup.
    Do I need to manually upgrade as well as check the additional usergroup myself?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It should add them to the group.

    What criteria are defined for the promotion?
     
  3. Tim Jay

    Tim Jay Active Member

    My concern with this is that if I have to add the usergroup manually then the subscription won't even remove the usergroup when it's over..

    If it's not adding, then how on earth would it know to remove.

    Wait, do I need to setup a promotion for user upgrades?
     
  4. Tim Jay

    Tim Jay Active Member

    I have an upgrade called 1 Month Subscription, Additional User Groups: Subscriber.
    (Puts the user in the selected groups while the upgrade is active.)

    I go to Manually Upgrade User for 1 Month Subscription, fill in the username & "Upgrade User".

    Now this user is showing up under Active User Upgrades. When I click on his user, he is not in the Subscriber usergroup like he should be.
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have any user group promotions which may be conflicting?

    Check the user change log to see what is happening for the user.
     

Share This Page