Implemented Make Media Gallery images linkable

Gator

Well-known member
When you add an image in a post using the "Galley Embed," you must click on the title to see the original image in the Media app. It would be nice if you could add the link to the image itself. As seen below, nothing happens when you click on the image.

I am using XenForo 2.1 Beta 6

 

snoopy5

Well-known member
Very good idea! This behaviour (only the click on the title leads to the image in MG) is still the same in MG 2.1rc
 

Mike

XenForo developer
Staff member
We have actually just changed this in MG 2.1. Note that this really only applies to images -- embeds and videos would generally already have their own behaviors from clicking on the image itself. The info block below the image is the only way to definitively get to the media page regardless of the type of content being linked.
 

snoopy5

Well-known member
That's great news. Thanks, Mike :)
I think you misunderstood Mike's response.

If you insert an image via "Galley Embed," it will not be clickable in the posting in 2.1.rc2 (at least not in my testinstallation).

In this special case of "Galley Embed," only the filename below that image is clickable.

Look here:

1. gallery embed:





2. Copy image link




3. Copy image BB code





4. Copy URL BB code with thumnail

 

snoopy5

Well-known member
error: I was wrong. It really now works. At least here.

I have to check why this does not work in my testinstallation
 

Mike

XenForo developer
Staff member
You haven't done anything wrong. It isn't in a released version yet. It is changed in the next 2.1 release (RC3 or 2.1.0).
 

Nuno

Well-known member
@Mike

I would like to suggest to uniform all embedded images in posts with the same behavior and with lightbox if possible.

Attachments + proxy images and embedded gallery images using BBCode have different behaviors.

Thanks
 
Top