• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

[MAJOR] Users logging in as other users!

#1
Hello Xenforo community,
Lately I have been experiencing a weird MAJOR bug at my forums (http://www.happy-hg.com/forum/) in where RANDOMLY there is a very low chance of an user when logging in to it's account, to be logged with someone else's account instead of theirs. I have no idea what are the steps to reproduce this bug as it's completely random and it can happen with any account logged in from any user.
Furthermore, I have checked my errors log and I found two errors from some days ago, I have no idea if these errors have anything to do with this bug but I'll paste them here anyway: http://pastebin.com/rJbr8tRT
Xenforo Version: 1.5.0
Please Help!
Thanks
 

Brogan

XenForo moderator
Staff member
#2
I have moved this from bug reports to troubleshooting.
If it was a bug we would have had more reports of it.

Does it happen with all add-ons disabled?
 
#3
I have moved this from bug reports to troubleshooting.
If it was a bug we would have had more reports of it.

Does it happen with all add-ons disabled?
I only have 3 small add-ons, I'll try disabling them and reply back if it kept happening.
Thanks
By the way, Apparently this happens later, when someone logs in it logs him/her normally to it's account but when they refresh the page they find themselves randomly logged in as another account, really weird...
 

Mike

XenForo developer
Staff member
#6
This is likely caching on the server level, such as with Varnish. I would contact your host to see if they are doing anything like that. XenForo specifically sends headers to prevent caching like that but it sounds it's being disregarded.