• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug Mails only were sent by smtp when MailQueue activated

Affected version
beta 4

Marcus

Well-known member
#1
I disabled MailQueue in config.php, and only after I enabled this setting, notification emails arrived in my inbox.
 

Kier

XenForo Developer
Staff member
#2
Just to clarify, do you mean emails that were already 'in the outbox' weren't sent, or new notification emails?
 

Marcus

Well-known member
#3
After I set MailQueue = enabled, #1 (sure) I did not receive more of these error messages and #2 (pretty sure) I received emails from my forum, as much as I remember. I am not 100% certain as lot of things happened ( I moved also to a new server during xf1-xf2 upgrade ).
 

Mike

XenForo developer
Staff member
#4
It's worth noting that if you disable the queue, that will stop processing anything that's in the queue already. If you re-enable it, those mails will still potentially be sent. (Thus if you disable the queue, you should empty it manually if necessary, though really this is more of a potential debugging thing. Arguably, we should just remove the option.)