1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

As Designed Long topic titles are not trimmed

Discussion in 'Resolved Bug Reports' started by dtommy79, Aug 18, 2011.

  1. dtommy79

    dtommy79 Member

    Hi,

    I've noticed that longer topic titles won't get trimmed on the main page. Look below:

    topic.png

    I have the latest version of xenforo installed, it happens on custom skins and default as well, but only when using different language set.

    When I switch the language back to english the problem dissappears.
     
  2. Mike

    Mike XenForo Developer Staff Member

    This is the designed behavior as your translation is a fair bit longer than the English version.
     
  3. Steve F

    Steve F Well-Known Member

    Mike, I have the same thing happening on a style I customized the font on. I changed the body font to this:
    Code:
    'Verdana', Trebuchet MS, Helvetica, Arial, sans-serif
    Reverting the body style property fixes the issue.

    lastpost.png
     
  4. Mike

    Mike XenForo Developer Staff Member

    You need to edit the template to shorten the length of the title snippet. You can see that most cases fit - it's where there are especially wide characters (lots of caps) that don't.
     
    Steve F likes this.
  5. dtommy79

    dtommy79 Member

    Hi Mike,

    Check my forum main page here.

    Some of the titles are shortened properly while some aren't. If it is because of the longer titles the then why some are shortened properly?
     

Share This Page