Login as User (LAU2)

Login as User (LAU2) 1.2.4

No permission to download

au lait

Well-known member
au lait submitted a new resource:

Login as User (LAU2) - Log in to another user's account with a click

Administrators can log in as User X with this add-on. Login via the admin bar or via the member profile. Of course, this is only possible with the correct permission.

This helps e.g. to better understand problems a user has in order to be able to help him.
A link in the admin bar will allow them to quickly return to their own account at any time.
Read more about this resource...
 

Wilouness

Active member
Why is it so hellish to download a free addon?
i thaught i was the only one !! So complicate to access the downlaod button
You have to checkout your Cart on his webside proceed to payment for the free addon and after that visit the "Your License" menu add the url of your website where you're gonna install the addon and finally find the "Download" button at the bottom on the right !!o_O
 
Last edited:

Niro

Active member
Great add-on, thank you, but is there an option to get back to your account after you finished to visited another member ?

Thanks :)
 

au lait

Well-known member
Why is it so hellish to download a free addon?
i thaught i was the only one !! So complicate to access the downlaod button
You have to checkout your Cart on his webside proceed to payment for the free addon and after that visit the "Your License" menu add the url of your website where you're gonna install the addon and finally find the "Download" button at the bottom on the right !!o_O
I have to agree. Great add-ons but the download process is kind of a labyrinth.
I understand your displeasure!
It is only necessary to create an account once and validate the license. It'll be easier after that. But yes, it has to be and it is the same with many others. I want to stay in control (at least a little bit).
 

djbaxter

Well-known member
I understand your displeasure!
It is only necessary to create an account once and validate the license. It'll be easier after that. But yes, it has to be and it is the same with many others. I want to stay in control (at least a little bit).
I understand that.

You only have to enter the license once. But you have to enter the forum URL for every download, even upgrades and even if you only have one forum.

But the biggest problem I have on your site is you have to click several links in order to even get top the download page. And once you're there, even then it's confusing as to how you can actually download the add-on.

You don't necessarily need to change your system. But what is needed is much clearer instructions on what to do now and what to do next to get to the downloads page. As it is now, it's very confusing, especially the first time when I found myself clicking here and there and then having to click the back button on the browser, and repeating this cycle several times before I finally figured out what your syustem was asking me to do.
 

au lait

Well-known member
But the biggest problem I have on your site is you have to click several links in order to even get top the download page. And once you're there, even then it's confusing as to how you can actually download the add-on.
Yes I have already informed the manufacturer! In addition, I already made changes to the style today so that it is more visible for download.

But you have to enter the forum URL for every download, even upgrades and even if you only have one forum.
No
As soon as the license has been activated correctly - a download is possible countless times without re-entry!
But yes, if you purchase another license, you need to enter the URL again for the new license.
Since it is not clear on which URL they will use the new license.

as i wrote above, i have tried to prevent the complicated way to download.
 

djbaxter

Well-known member
Yes I have already informed the manufacturer! In addition, I already made changes to the style today so that it is more visible for download.


No
As soon as the license has been activated correctly - a download is possible countless times without re-entry!
But yes, if you purchase another license, you need to enter the URL again for the new license.
Since it is not clear on which URL they will use the new license.

as i wrote above, i have tried to prevent the complicated way to download.
No. I entered the license only once, that's correct, and I have not been asked to do that again.

But when you upgrade an addon, like Top Posters of the Month, each time there is an upgrade, I have to enter the URL of the forum where it will be used again, even though I've already entered that for the previous two versions of the same upgrade. Do you see what I mean?

On most sites away from Xenforo.com, for either Free or Paid add-ons, you need to enter a site license and the URL attached to that site license, This only needs to be done once. After that, you don't need to reenter that information to download upgrades or to purchase new add-ons - it's already present in your account so you are now approved for downloads. If you acquire a second license or change the URL of the forum attached to your license, you do that directly in your account profile; it doesn't need to be repeated for each download.
 

au lait

Well-known member
But when you upgrade an addon, like Top Posters of the Month, each time there is an upgrade, I have to enter the URL of the forum where it will be used again, even though I've already entered that for the previous two versions of the same upgrade. Do you see what I mean?
According to the manufacturer and also after my own test this is not correct!
 

au lait

Well-known member
a) please continue the discussion on xenMade.com. This is not the correct thread for it!
b) here is a test (also Free) -> https://xenmade.com/xenmade-addons/test.47/ We can test and provide updates. And they can make a little video of their problem. That's probably the best way.
But in this thread never please! Please also discuss problems with xenMade there.

Tomorrow I will ask for the deletion of contributions which have nothing to do with the subject.




Edit:
by the way. The manufacturer has already made changes that simplify the download and also the purchase of Free Adons. I think I can install the new version after my vacation.
 

RSI

Active member
This add-on works really well and finally, but I noticed when you log in as a member it shows all of the forums as not being read. Any way to make it display the members correct read status?
.
.
 

au lait

Well-known member
This add-on works really well and finally, but I noticed when you log in as a member it shows all of the forums as not being read. Any way to make it display the members correct read status?
.
.
there are no problems here

Screen_20180901103954.png

Screen_20180901104007.png
 

au lait

Well-known member
au lait updated Login as User (LAU2) with a new update entry:

1.1.0

[add] Reason
[add] Disallowed Users
[add] Login Log
[add] Stealth Login
[notice] So things that are read are not displayed as such for the user.

[add] Option: Stealth Login
[add] Option: Display "Login-Button" in profile
[add] Option: Display "Login-Button" in Staff-Bar
[add] Option: Reason is required
[add] Notice: That you are in a different profile
[*] Several improvements / design/phrasen improvements
Read the rest of this update entry...
 

RSI

Active member
au lait updated Login as User (LAU2) with a new update entry:
That's works a lot better. I was trying to figure out what was going on because yesterday morning I thought it was somehow browser related then realized that it wasn't happening with every account I logged into. The only thing I can figure is that it was somehow unstable and was coming up in stealth mode at random, but now we can force it one way or the other. Not sure if that was the problem or not.

P.S. After the update I had to uncheck all of the boxes when in Options and save it, then go back a select the ones I wanted again. I actually had to do that a couple of times before it started working correctly.
.
 

au lait

Well-known member
P.S. After the update I had to uncheck all of the boxes when in Options and save it, then go back a select the ones I wanted again. I actually had to do that a couple of times before it started working correctly.
.
I don't understand! These are normal XF options which should not (should) cause any problems.
 

RSI

Active member
I don't understand! These are normal XF options which should not (should) cause any problems.
Maybe it was because I upgraded from the first version and every setting just didn't take when upgrading. I've seen that happen before with other add-ons where you have to uncheck the boxes after and save then put them back and save again to get them to take. Maybe someone doing a fresh install with the latest version wouldn't have any trouble.

Anyway great add-on. Like everyone else though why is it free? I would have paid for it too ;)

Oh, this might not be the right place to mention it, but we also desperately need another ACP add-on, hint, hint. Need a way to customize the widgets on the ACP’s homepage for one and a way to turn the add-on icons at the left side of each add-on on and off. That often causes my ACP to freeze when trying to display them because my hosting company limits my number of connections and it tends to go over when in the ACP once and a while.
.
 

au lait

Well-known member
Oh, this might not be the right place to mention it, but we also desperately need another ACP add-on, hint, hint. Need a way to customize the widgets on the ACP’s homepage for one and a way to turn the add-on icons at the left side of each add-on on and off. That often causes my ACP to freeze when trying to display them because my hosting company limits my number of connections and it tends to go over when in the ACP once and a while.
.
the right place -> https://xenmade.com/forums/add-on-requests.86/ :)

Like everyone else though why is it free? I would have paid for it too ;)
You are welcome to donate :)

Anyway great add-on.
thanks :)

Like everyone else though why is it free?
This add-on was, when it was created, not a big project and out of the mood...


Maybe it was because I upgraded from the first version and every setting just didn't take when upgrading. I've seen that happen before with other add-ons where you have to uncheck the boxes after and save then put them back and save again to get them to take. Maybe someone doing a fresh install with the latest version wouldn't have any trouble.
I have made many updates from the old to the new one - and never had problem in this, especially since it is XF basic.
Very very strange.
 

Sunka

Well-known member
If I login as user and read some thread with unread post in it, and then log out from that user, will that user when come back to forum have that posts as unread or read?
 
Top