1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Just imported, checking my server logs

Discussion in 'Troubleshooting and Problems' started by Ludachris, May 19, 2014.

  1. Ludachris

    Ludachris Well-Known Member

    Opened the site to the users and got a few of these errors in the server logs:

    ErrorException: Division by zero - library/XenForo/ControllerPublic/Thread.php:588

    #0 /home/site1/public_html/library/XenForo/ControllerPublic/Thread.php(588): XenForo_Application::handlePhpError(2, 'Division by zer...', '/home/site1/...', 588, Array)
    #1 /home/site1/public_html/library/bdSocialShare/XenForo/ControllerPublic/Thread.php(9): XenForo_ControllerPublic_Thread->actionAddReply()
    #2 /home/site1/public_html/library/DoublePost/ControllerPublic/Thread.php(42): bdSocialShare_XenForo_ControllerPublic_Thread->actionAddReply()
    #3 /home/site1/public_html/library/XenForo/FrontController.php(347): DoublePost_ControllerPublic_Thread->actionAddReply()
    #4 /home/site1/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #5 /home/site1/public_html/index.php(13): XenForo_FrontController->run()
    #6 {main}

    Does this mean there's a problem with the bdSocialShare plugin or core? I see the bdSocialShare line in there.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It could be related to that add-on, yes.

    Contact the developer and check with them.
  3. Tracy Perry

    Tracy Perry Well-Known Member

    That, or it looks like you have @Syndol's DoublePost add-on installed also. Could be one or the other or an interaction between the two.
  4. Ludachris

    Ludachris Well-Known Member

    I'll check with both developers. Thanks! I'm also seeing a lot of server errors with the XenCentral add-on. Wonder if there's a conflict with a couple of these add-ons.
  5. Tracy Perry

    Tracy Perry Well-Known Member

    That is a possibility - especially if they both deal with posting related factors.
  6. Ludachris

    Ludachris Well-Known Member

    I just disabled both the Doublepost plugin and the bdSocialShare plugin and am still getting Division by Zero errors in the logs... here's an example of another one:

    ErrorException: Division by zero - library/XenForo/ControllerPublic/Thread.php:293
    Generated By: Myst11, Yesterday at 10:03 PM
    Stack Trace
    #0 /home/site1/public_html/library/XenForo/ControllerPublic/Thread.php(293): XenForo_Application::handlePhpError(2, 'Division by zer...', '/home/site1/...', 293, Array)
    #1 /home/site1/public_html/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Thread->actionUnread()
    #2 /home/site1/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #3 /home/site1/public_html/index.php(13): XenForo_FrontController->run()
    #4 {main}
    Request State
    array(3) {
    ["url"] => string(85) "http://www.site1.com/threads/carbon-creations-2gb-front-lip-special.478401/unread"
    ["_GET"] => array(0) {
    ["_POST"] => array(0) {

    How can I narrow down the problem?
  7. Mike

    Mike XenForo Developer Staff Member

    The error appears to be the "messages per page" option. You seem to have 0 for that, which isn't a valid value for it (so not sure how that happened).
  8. Ludachris

    Ludachris Well-Known Member

    Ahhh, maybe it's due to the "Threads and Messages Per Page Preferences" plugin that I just now disabled. I installed it before the final migration but have since read about how it has the potential to break links due to how the page # is built into the URL structure. I'll keep monitoring the logs to see if that fixes the errors.
  9. Ludachris

    Ludachris Well-Known Member

    No errors yet. Thanks Mike, just pointing that out might have helped narrow it down.

Share This Page